WordPress.org

Support

Support » How-To and Troubleshooting » Edit Home Page

Edit Home Page

  • I know this sounds stupid, but I have a home page, but when I go to edit pages it is not listed. How do I find this page to edit?

Viewing 15 replies - 1 through 15 (of 19 total)
  • Samuel B
    Participant

    @samboll

    perhaps you are set to show posts instead of a home page?
    edit the posts, instead

    the setting for posts or static home page
    admin – settings – reading

    julie.wuthnow
    Member

    @juliewuthnow

    I tried doing this, and had no problem editing the individual posts, but this still doesn’t change the format of what is appearing when I’m on the home page itself (which shows ‘your latest posts’, rather than static page on the settings page you indicated above). I’ve been wanting to change the default Multimedia Box Image that comes with Thesis, but my changes only show up on pages after I’ve opened individual posts.

    Thanks

    p.s. have just updated to wordpress 2.8.2

    HELP! I’m having the same problem. Did you ever resolve it? I want my “Home” page to edit like my other pages. In my Admin I don’t even have a “Home” page to edit. I can only add content to my “Home” in the form of posts. HELP!

    Johnny Bravo
    Member

    @herbiehysteria

    your ‘home’ page is never listed as ‘home’ in dashboard>pages, it will be listed as whatever u called it.

    Ok… figured it out.

    Make a New Page called “Home”

    Go to Settings -> Readings -> and change Front Page to “Home”
    and make sure “Static Page” is selected.

    knobcottage
    Member

    @knobcottage

    wow worked for me too! just can’t get the edit feature off the page, despite telling wordpress that the page can’t be edited

    Now I can navigate back to front page. Thanks,but I had to create a page because I had to pick a page name from a dropdown with my pages on it.

    I did this and it worked except I now I have 2 home pages listed on the menu? They seemed to be the same page just listed twice on the menu? How can I fix that?

    beheader69
    Member

    @beheader69

    you can,t unfortunately

    esmi
    Forum Moderator

    @esmi

    Yes you can.

    Hi
    Esmi is correct, you can.

    [link moderated – if you have videos and tutorials that are helpful please submit them to http://wordpress.tv/ and use those links]

    You have to modify the wp_list_pages function in your theme to exclude the second link.

    maureenvs
    Member

    @maureenvs

    This is the exact issue that has left me frozen in my tracks. I tried different themes on an alternate website and same thing. The only way to add content to the home page (since it’s not in the edit pages section) is the add content as a post. I need my front page to look like a website so I don’t like that solution.

    This seems so basic and can’t figure out why it’s designed this way. There must be a reason, right?

    Wishing for a solution….

    esmi
    Forum Moderator

    @esmi

    maureenvs
    Member

    @maureenvs

    I did this but then there are two “home” pages as you can see here: http://blissfestkc.com/

    I called the second one “welcome” but how do I get rid of or hide the first one?

    “Creating a static front page on wordpresstv:

Viewing 15 replies - 1 through 15 (of 19 total)
  • The topic ‘Edit Home Page’ is closed to new replies.