[resolved] edit gallery settings are weird; a mystery checkbox; no selectable orders (7 posts)

  1. Glen Rowell
    Posted 1 year ago #

    Edit Gallery → GALLERY SETTINGS

    Link To "Drop Down (Attachment Page/Media File/None)" Columns
    "checkbox" "Drop Down (1-9)" Random Order

    The options area is really weird. I don't know what the checkbox is for and there aren't any order options, I can just see the text "Random Order". Also I thought the auto option was being added to the 1-9 dropdown from the Media Grid Plugin test. http://wordpress.org/ideas/topic/wordpress-media-gallery-please-that-cant-be-true/page/9

    This update almost has everything we need without having to add heaps of plugins finally. Thank you so much everyone for all your hard work ^^

  2. It looks like this for me: https://cloudup.com/cJOG0y2YGjC

    So that's clearly

    Link To: Attachment blah
    Columns: Dropdown
    Random Order: Checkbox

    Which means if I check the box, I get a random order of images.

  3. Glen Rowell
    Posted 1 year ago #

  4. Your fonts are wrong too....

    Flush your browser cache and set up script_debug: https://codex.wordpress.org/Debugging_in_WordPress#SCRIPT_DEBUG

  5. Glen Rowell
    Posted 1 year ago #

    I cleared the cache and reset Chrome in the advanced settings area.

    I also added this code to the bottom of wp-config.php

    // Enable WP_DEBUG mode
    define('WP_DEBUG', true);
    // Enable Debug logging to the /wp-content/debug.log file
    define('WP_DEBUG_LOG', true);
    // Disable display of errors and warnings
    define('WP_DEBUG_DISPLAY', false);
    // Use dev versions of core JS and CSS files (only needed if you are modifying these core files)
    define('SCRIPT_DEBUG', true);
  6. Glen Rowell
    Posted 1 year ago #

    That seemed to have fixed the problem ^^

    Can you add the Link To "Custom URL" from Image Details > DISPLAY SETTINGS > "Custom URL" to the gallery?

    I made a plugin to do this but your programming is probably a million times better than mine.

    Also if "auto" is added to the 1 to 9 image selection part of the gallery like in the plugin that was made then this core component will work just the way any other gallery usually works. Which is a great thing. If standard images can link to "Custom URLs" I just imagine gallery images would work exactly the same way. I was always confused when I started using WordPress, wondering why I could only link single images to custom URLs. I was trying to use the gallery as navigation because it was so easy to set up and looked really good having images instead of a text based menu.

    The code in the template area to show the thumbnails has an auto column width in a way. Thumbnail sizes are set and the images tile perfectly across big screens which is very nice.

    You can see what I did with the gallery here:


    It is a standard gallery with Custom URL built in.

    I'm rebuilding my whole site from the ground up in this newer version of WordPress to get rid of lots of bugs and hopefully can delete 40 or so plugins from my last site. ^^

  7. Right so WHY it wasn't working was cached JS/CSS is all. Sometimes things are sticky.

    There's no way a link-to for custom URL will make it in for the gallery for 4.0 - There is a ticket for it somewhere out there but that's a feature req and not a bug fix for 4.0.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.