Support » Plugin: WooCommerce 'Email Money Transfer' Payment Gateway » Edit email content text.

  • Resolved jonathanappleseed

    (@jonathanappleseed)


    Hi there,

    I need to include the payment info in the email, but for some reason the email says, “After placing your order, please send an Email money transfer to the following:”

    That is after the customer has already placed an order. How do I edit this text?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Contributor Massoud Shakeri

    (@massoudshakeri)

    Hi,
    If in the Woocommerce->Settings->Checkout->Email-money-transfer in description field, there are html tags that is not closed, it may corrupt the rest of the content. So if that’s the case, please make sure all the html tags are closed.
    The latest version of this plugin only includes this instructions to the email_instructions of “processing”, “pending”, and “on-hold” statuses, so it should not be in completed order email.

    That was helpful information about the corruption of tags in the emails…

    But it is still, unfortunately, in the completed order email…

    Actually, it is not being input into the “Processing Order” emails, which is very nice. I don’t want it there either, since that wouldn’t make any sense. But it is still appearing unwanted in the “Completed Order” emails.

    Is there anything I can edit in the short term to make sure it doesn’t show up there?

    Plugin Contributor Massoud Shakeri

    (@massoudshakeri)

    first make sure you have the latest version of the plugin.
    If you have modified the email template of woocommerce->Settings->emails->Completed order, please check what may cause this.
    If you edit the plugin php file, line 350, it should read like this:
    public function email_instructions( $order, $sent_to_admin, $plain_text = false ) {
    if ( $this->instructions && ! $sent_to_admin && ’emt’ === $order->payment_method && ( $order->has_status(‘on-hold’) || $order->has_status(‘processing’) || $order->has_status(‘pending’) ) ) {
    you can remove “$order->has_status(‘processing’) || ” part of it, if you do not want that instruction in processing email.

    Ok, doing that removed the emails from my Completed Order message. Thanks for the quick fix. Not sure what to do about this after updates.

    Plugin Contributor Massoud Shakeri

    (@massoudshakeri)

    Please tell me what exactly you did to fix it

    As you suggested, I removed “$order->has_status(‘processing’) ||” from the plugin php file.

    Thanks again for all your help!

    Plugin Contributor Massoud Shakeri

    (@massoudshakeri)

    It means woocommerce is mixing “processing” status with Completed” status. because what you did is about processing status, and it affects the completed email.
    Hopefully for the next version, I will come up with a better solution.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Edit email content text.’ is closed to new replies.