Support » Fixing WordPress » Edit button shows up in post html

  • Resolved Jack

    (@moxie)


    This is weird. I’m writing a post and suddenly I see two instances of this code inside my post under the text that I’m writing (text tab). It doesn’t show up in the visual tab or on the website, but it is defenitely saved within the post.

    Any idea where this comes from?

    <span style="border-radius: 2px; text-indent: 20px; width: auto; padding: 0px 4px 0px 0px; text-align: center; font: bold 11px/20px 'Helvetica Neue',Helvetica,sans-serif; color: #ffffff; background: #bd081c no-repeat scroll 3px 50% / 14px 14px; position: absolute; opacity: 0.85; z-index: 8675309; display: none; cursor: pointer; top: 44px; left: 837px;">Bewaren</span>

Viewing 8 replies - 16 through 23 (of 23 total)
  • Hi Jack,

    If it’s really only WordPress and Twenty Fifteen you are running and it’s a WordPress issue we should be able to replicate. Since that’s not the case (at least, I can’t) I think it’s possible it’s an browser generated issue (for example something JS). Have you tried a different computer (or browser to start with)?

    Does your browser have any extension or similar add-on having anything to do with “Pinterest”?

    I ask because I noticed this in that code block:

    z-index: 8675309;

    That is distinctive. For those unaware, 867-5309 is a rather well known Tommy Tutone song. There’s no real reason to set that as a z-index.

    However, a Google search for that reveals that the same z-index value has been associated with a Pinterest extension in the past:

    https://wordpress.org/support/topic/unwanted-pintererest-code-in-wp-html
    http://www.telerik.com/forums/users-with-pinterest-browser-plugin-get-extra-code-added-to-html

    The Pinterest Bookmarklet code also uses that same z-index:
    https://gist.github.com/sebm/2369675

    So, my first thought would be to examine your browser in detail, looking for anything having to do with Pinterest.

    esmi

    (@esmi)

    Forum Moderator

    Oh – that’s such a cool piece of code sleuthing!

    Guys, that seems to be it! I have a Pinterest addon in Firefox, and once I deactivated that the code doesn’t show up anymore! I would have never thought about a browser/addon problem. Thanks Otto, and everyone else ofcourse, to find the solution. 🙂

    Otto Thank you!!!! So much appreciated! We had this exact same issue as well and had not had any luck with theme/database/file troubleshooting either. Always felt it wasn’t specifically website related because it was presenting on multiple sites. Never thought about a browser/addon either.

    SO grateful!!! Thank you!!!

    Thanks for posting. We just noticed this on one of our sites tonight, and yes we do have a Pinterest addon for Firefox.

    And yes, kudos for recognizing the Tommy Tutone reference. LOL.

    LAB18

    (@lab18)

    Huge thanks from me too – same problem and had no idea it was the Firefox Pinterest pin it addon… until now.

    Gerry2014

    (@gerry2014)

    Good work Samuel Wood (Otto). We too had the same problem on all of our websites. A total mystery until now. Thank you.

Viewing 8 replies - 16 through 23 (of 23 total)
  • You must be logged in to reply to this topic.