Support » Plugin: Ecwid Ecommerce Shopping Cart » Ecwid Plugin filling wp_options table with 1GB (56,000 records)

  • Resolved ext237

    (@ext237)


    I provide technical support for two Ecwid clients. One is a very busy store, the other has less traffic.

    Both have wp_options tables in excess of 1GB of data. There are thousands of rows (as many as 56,000 records on one site) stuffed into the wp_options table related to the Ecwid plugin.

    This is an extreme overuse of that table, and it’s affecting the website’s general performance, causing issues with creating backups and exceeding the web hosting’s size limitations.

    For a small store with less than 300 products, using a shared server platform for hosting, this makes the Ecwid plugin virtually unusable.

    This is a critical bug that needs to be addressed immediately.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Hi @ext237,

    This is Ilnur from Ecwid.

    Thank you for your message about this issue. WP should automatically clean up expired transients records. You can check the WP cron task for removing transients. Make sure the “delete_expired_transients” task is enabled on your sites.

    Anyway, we’ll see how we can improve the plugin`s cache feature.

    Workaround – you can forcefully clear the plugin cache. Open the page “/wp-admin/admin.php?page=ec-params” and click the “Clear all caches” link at the bottom of the page.

    Stay tuned for the next releases.
    Regards,

    Thread Starter ext237

    (@ext237)

    Already checked delete_expired_transients, it is enabled and when I triggered it manually there was no change in table size.

    I didn’t know about page=ec-params. Just did that, clicked clear caches. Page refreshed, no status code or error code. wp_options table size is still > 1.1GB.

    Most records are “_transient_ecwid_products_****” and “_transient_timeout_ecwid_products_***”

    We need to resolve this before the next release.

    You can delete these records manually, for example using phpMyAdmin.

    Are you using a multisite feature in WordPress?

    Thread Starter ext237

    (@ext237)

    Not multisite, two individual sites on different servers. Sorry, logging in every few days to do this manual isn’t how this should work. This is an issue that needs to be handled by the plugin, right?

    Thread Starter ext237

    (@ext237)

    I was able to remove them from one of the sites by disabling the Ecwid plugin and then re-enabling it.

    Our support team will write to you as we need to get some details.

    Ilnur Basyrov

    (@meteor1ecwid)

    Hi, @ext237

    We are terribly sorry for this issue. We are preparing a patched version of the plugin and will send it to you by email soon.

    Thread Starter ext237

    (@ext237)

    I received an email from Support. They asked me to install the plugin and then go to this page to clear the cache: /wp-admin/admin.php?page=cparams

    The plugin is already installed, that’s how I found this issue. And the cparams page didn’t resolve the issue when it was first suggested several days ago. They did not send a patched version.

    Thanks for any help or suggestions you can provide.

    • This reply was modified 7 months ago by ext237.

    Sorry for the miscommunication. We’ve sent a new email with the patched version. Please check it.

    Hi @ext237!

    I just wanted to know if the patched plugin helped?

    Thread Starter ext237

    (@ext237)

    I got another over-size database error today, so I installed the plugin. How long should it take before it clears the records? I clicked clear cache from the ec-params page, but the page just refreshes, no messages, warnings or errors — and the database options table remains at 1.1 GB. Is there a delay when using the ec-params page to clear the cache?

    Thread Starter ext237

    (@ext237)

    Hello, can I get an update? I got another complaint email from my web host and I forwarded it to your support team. They replied by sending me the same patched plugin and instructions to click the clear cache button.

    But as mentioned, neither of those work. The only thing that resolves the issue is logging into the server every couple of days and running the database optimization feature of the WP-Optimize plugin. Having to do database maintenance every two days is not going to work for us.

    Thanks.

    Hello! It’s Lewis, Ecwid team!

    May I ask you to contact us at support@ecwid.com and send the login and password for the admin account on your website, so it will be possible for us to check if everything is correct on your website.

    You can create an admin account under support@ecwid.com and send a password to us.

    Also, please, note in the email that this is for Lewis K.

    Thank you!

    Thread Starter ext237

    (@ext237)

    Looks like the patched version you sent me has resolved the issue, I haven’t received messages from the host in quite a while. Thanks for the help.

    Hi, @ext237!

    Thank you for your feedback about the patched version, it will help us improve our plugin.

    Sorry for the inconvenience caused.

Viewing 15 replies - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.