Support » Requests and Feedback » Ecto Image Upload Resolution?

  • Okay,

    I’ve posted about this in the past, and so have many others: A lot of us are ecto users, and proud WordPress users.

    What do we have to do to get image uploading to work? We’ve tried the ecto forums and it has been pointed out, time and time again, that this is a WP problem. Since ecto uploads fine on other platforms, I really have to ask: is anyone working on this? Apparently it has something to do with the xmlrpc(?) file.

    Please, if anyone can fix this, it would be very much appreciated. This has been driving me crazy for a long time.

    To answer your questions before you ask:

    Yes, the image upload directory in ecto has been set to default.

    Yes, I’ve tried it with the full path.

    Yes, all my directories and subdirectories which I am uploading to are set to 777.

    Yes, it used to work just fine with WP 1.5.

    Yes, I have the latest WP installed.

    Yes, I’ve tried everything suggested in the forums here. It didn’t work, and it still doesn’t work. It gives me some sort of newmediaobject null() error when I try to upload an image.

    Yes, I know what a relative vs. full path is. I’ve tried both.

    I love WP. I know it’s free. I know that nobody gets paid squat for coding it up or fixing bugs.

    No, I’m not being critical. I’m just wondering: will it get fixed? Yes, I’ve seen a bug report on it in the past but I haven’t seen any resolution on it.

    Please let us know. It looks like I’m not the only one frustrated by this. Apparently Marsedit doesn’t work with image uploads either (so I’ve read)? So obviously, if this is the case, it has to be on the WP side. Please, please, don’t tell me to go back to the ecto forum and tell them to fix it. I’ve done that in the past and it was explained, in no uncertain terms, that it is a WP problem. Others have tried as well. Can somebody please look at this?

    Thanks for any info, tidbits, help, or fixes. Lots of kudos to you if you do actually fix this problem.

Viewing 5 replies - 1 through 5 (of 5 total)
  • I have had no problem with image upload in 2.x versions of WP. Do you have the correct path set in the Miscellaneous tab for image uploads (and the check box unchecked for letting WP create subfolders)? That was the only thing I had to set when WP moved from 1.5 to 2.0…

    I still can’t get ecto/wp to set categories in 2.03 though…

    Yeah, I do. I’ve been using WP to upload images and it works fine via the web interface.

    But not with ecto.

    As I have said: I’m not the only one with this problem with ecto (and other apps).

    I’m following Banagor around on this one, and like him I have tried just about everything I can. Adriaan, ecto’s developer, explains that the reason this is a WP problem, not an ecto problem, is that WP’s xmlrpc/server.php is doing the heavy lifting; all ecto is doing is sending it the data to lift.

    So why doesn’t it work?

    Yellowswordfish: You mean the check box next to Organize my uploads into month- and year-based folders? I’ll try unchecking that, but it would be nice to know WHY that should make a difference (if it does).

    Later: you are right. unchecking that does permit ecto to upload images. I’ll pass that on to Adriaan. Thank you.

    What do you mean you “can’t get ecto/wp to set categories in 2.03”? To create a new category from ecto? Or to get a new category created in WP back into ecto?

    For me this problem is intermittent. I post once, no problem. I post again half an hour later, and get the Ecto message “uploading x.jpg” along with the endlessly spinning widget. Usually if I quit Ecto and restart, everything works fine. Every once in a while, I have to restart twice. Annoying, but it works. I haven’t been able to identify the independent variable, whatever it might be.

    scarabus: Does any behavior change if you remove everything from “Update Services” (Options:Writing)?

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Ecto Image Upload Resolution?’ is closed to new replies.