Support » Plugin: EasySMS » easysms from header

  • Resolved ilabs


    I’m really hoping someone can help me with this. This is a great plugin with a bit of tweaking but it seems the author has disappeared.

    I have everything working, except that when a message is received it shows the default apache server Envelope-sender as the From: address. I have tried to use the 5th parameter for the mail() function to include the -f flag, but apparently I am not editing the right portion of the plugin.

    Example (not working):
    wp_mail($to, $subject, $message, $headers . "\r\n", "");

    This works for me using other plugins, such as Contact Form 7, but not the easysms plugin. Any help is more than appreciated!

    My site:

Viewing 1 replies (of 1 total)
  • For what it’s worth I’ve found a solution.

    If you are using the EasySMS plugin and your readers are receiving emails with a from address that looks like “” then here is what you want to do:

    The file to edit is called sms_message_menu.php which is located within the easysms folder.

    There are 3 lines of code within 3 functions that need edited. Each line looks like:
    if (mail($to, $subject, $message, $from,))

    You simply need to add the -f flag and 5th parameter to the end of the mail() function with your return email address to pass the Envelope-sender through to the server.

    Like this:
    if (mail($to, $subject, $message, $from, ""))

    I hope this helps, I’m sure there’s gotta be someone else who has this same dilemna. As for the plugin, I wish I were better with php, a bit of tweaking and this would rock!

Viewing 1 replies (of 1 total)
  • The topic ‘easysms from header’ is closed to new replies.