Support » Plugin: RediSearch » Easyengine integration

  • Resolved seyntjim

    (@seyntjim)


    Hello,

    I really like this plugin. My website has almost 40k posts and I’m planning of replacing relevanssi to redisearch plugin. The problem is I can’t make it to work. I successfully installed redisearch via docker since easyengine is using docker. When I try to connect to redisearch with redis-cli -h ip command, it’s working fine. But when I try to set it up on your plugin, it says there’s a problem connecting to redisearch.

    I can give you my test server info to look what is the problem.

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author foadyousefi

    (@foadyousefi)

    Hi

    Thanks for trying my plugin. It seems there are some problems connecting to redis-server running via docker container and I need to dive deeper.

    Having access to the test server would be helpful. You can contact me via my email. In this image, you can find my email address: https://cloudup.com/cTU5jtCGbt7

    (After I’ve got an email from you, will remove this link).

    seyntjim

    (@seyntjim)

    Thank you! You can now delete the link. I saved your email. I’ll email you once I setup the test server.

    seyntjim

    (@seyntjim)

    I just sent you an email. Thank you.

    Can you please kindly share the tech into and solution? I’m also using redisearch in cocker container and I think that is same reason why I’m also having connection issues.

    When I try from CLI everything works fine

    Plugin Author foadyousefi

    (@foadyousefi)

    @seyntjim

    I did some tests and seems there are multiple docker containers running on your server. I’m not familiar with your server setup, that’s why I didn’t touch anything. Could you please stop all containers running redis server and only run following command:

    docker run -p 6379:6379 redislabs/redisearch:latest

    This command will run a redis-server instance in docker container which RediSearch module is already loaded. So the instance can be used for all redis related tasks (usual caching plus RediSearch).

    @foadyousefi

    I tested it with only one docker container running and still it’s not working. Please check your email for more info. Thanks!

    Plugin Author foadyousefi

    (@foadyousefi)

    @seyntjim

    Finally made it work. It has something to do with docker container. You need to link redisearch container with mail container. Here is how you do it:

    First, check your container by running docker ps then find the main container which nginx is running from and check which network its connected to by running docker inspect <container-id> then check Networks object.

    Then you can run your RediSearch container like following:

    docker run --network=<network-name> --network-alias=<choose-alias> -itd --name=<some-name> -p 6379:6379 redislabs/redisearch:latest

    Then in the plugin settings page, enter your network alias in Redis Server and your selected port and everything should be OK.

    I hope this will be useful.

    @7grafix Can you also check if this work for you and let me know?

    @foadyousefi

    Finally, it worked! Thank you so much!

    Plugin Author foadyousefi

    (@foadyousefi)

    Cool!

    Also, thank you @seyntjim to let me use your test server to solve the issue.

    Plugin Author foadyousefi

    (@foadyousefi)

    Sorry for the typo:

    In the explanation for how to fix the issue, there is a typo where I say “You need to link redisearch container with mail container.”

    by mail, I mean main.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Easyengine integration’ is closed to new replies.