Support » Plugin: Easy2Map » Easy2Map Version 1.1.6 Site Loading Issues

  • Resolved CloaknDagger


    Since updating the plugin to its current version, 1.1.6, the site has slowed tremendously, sometimes not loading at all. After deleting each plugin one-by-one to see which one was causing the problems, the site load ultra fast once again once I deleted Easy2Map version 1.1.6. I have attempted to contact the publisher asking for a most recent previous version. Still waiting to hear back.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Same symptoms for me.

    Shame, as it’s normally a great little plugin.
    My upgrade actually caused a server fault, probably down to some short timeout on shared hosting.

    Was wondering if I could restore from a backup of the files in the plugin folder? Would it also need the DB restored, even if I didn’t mind setting plugin preferences again?

    Unfortunately, I had over 800 locations across 51 maps worldwide. I had to set up all new DB and basically start over from scratch. But I did recruit new assistance with the mapping this time. Keeping WP 3.5.2 until they get the problems resolved, as it works fast in that version of WP.

    From testing with Chrome is seems to be linked to jQuery versions.
    With Easy2Map enabled all pages take ages (20 to 30 seconds) to load resources such as jquery.js?ver=1.10.2:6

    With Easy2Map disabled the pages load as usual and no calls to this version of jQuery are made.

    I downgraded to a backup version, tried 1.1.1 and 1.1.5 and neither seem to work now on two of my sites.
    Another site that I hadn’t updated to Easy2Map 1.1.6 still works fast as you like.

    Plugin Author stevenellis



    My sincere apologies for the issues you are experiencing. I have done loads of testing on new and existing versions of E2M and can’t replicate this slowness. Can I ask, is the plugin admin manager also very slow to load, or is it only experienced on pages or posts that have an easy2map embedded?

    Will get to the bottom of it!!

    It is for the site as a whole. Didn’t matter if it was in the wp-admin area or signed out of WP Admin. Many others experienced as well. I personally use Windows 7 & 8, on my desktop and laptop, respecitively. Other people were using various mobile devices, PCs with various version of Windows and some were using MACs. I was running WP 3.6 with newest version of E2M. I down-graded WP to 3.5.2 with your most recent version. Runs great now. No one that had experienced the slowness before has not been experiencing it since the down-grade.

    Steven, thanks for the support on this.

    If it’s any help here’s more detail on my situation.

    WP 3.6, using E2M 1.1.5 was working fine and still have one site running fine on this version, not upgraded to E2M 1.1.6 yet.
    WP 3.6, upgrade to E2M hit problems during the upgrade process due to server timeout on one of my sites. So slowdown started during the installation of E2M 1.1.6.
    Disabled E2M 1.1.6 and site (all pages in Admin and public side) was back to normal.
    Uninstalled E2M 1.1.6 and uploaded E2M 1.1.1 plugin folder from a backup of the site. As soon as the plugin is installed the site slows again.
    Uninstalled E2M 1.1.1 and uploaded 1.1.5 from backup and site slowed again.

    Not sure if there’s more to loading the plugin than just copying the E2M folder from a backup of the site? Bit confused how downgrading the plugin doesn’t help when it was working fine with the older versions before. I verified the plugin folder and tables in the DB were removed after uninstalling each version. I verified the tables were created and populated with defaults after install.

    The smallest site I have this issue on also has these plugins enabled:
    “Contact Form 7”, “Easy FancyBox”, “Optimize Database after Deleting Revisions”, “Show Menu Shortcode”, “Soliloquy Lite”, “WordPress SEO”. It is using a child of Responsive theme from ThemeID, CyberChimps. There are minimal changes in the functions.php file as the site is still under development.

    As soon as I can I will try disabling all other plugins and set the theme to a WP supplied one to see if it makes a difference.

    Hope that will help.

    Plugin Author stevenellis



    I have made some changes to the codebase, base on research done into version 3.6 compatability. Specifically, I have removed a reference to an external JQuery library, which apparently the new version of WP doesn’t like (wants plugins to use the WP version of JQuery). That may have been causing the slow loading.

    I have uploaded it to

    if you are able to, please could you download it and see if it resolves your issue of slow loading. In either way, your feedback would be much appreciated.

    Works perfectly for me.
    Just been messing about with it for an hour or so and it seems to be back to its usual top-notch plugin.

    BTW, as I had to delete 1.1.6 before installing 1.1.7 I tried creating a dummy map in the WP Admin area, then went to edit the DB tables directly to copy my previously saved values back in over the top of the dummy map. When I did the map would disappear from the WP Admin area. The only time it worked was when I just edited the lat and lng for the map points.
    Obviously I must have been putting in badly formatted data, despite being careful to include/exclude quotes and new line characters etc.
    It has made me wonder if a restore of the plugin tables as a whole would work? Worth knowing my nightly backups can be restored if the worst should happen.

    Anyway, thank you very much for the work Steven.

    Just updated to E2M 1.1.8
    All good so far on two sites.

    Thanks again Steven.

    Plugin Author stevenellis


    Hey man

    That’s great news, very glad to hear that!
    Regarding the map disappearing from your admin area, not sure why that would be the case. Perhaps there was some issue with the XML not escaped correctly in the database table, or the mapPins not being linked correctly back to the map. Anyway, what you did should in theory work. If you have issues with that going forward, give me a shout and I can look into it further.

    To add a little more regarding backup/restore.
    I used an edited SQL file (to just leave INSERT commands for the tables I wanted) from mysqldump to add the data back to the maps and map_points tables. Worked great this time, so it must have been the way I was copying the field data manually back to the tables as to why it broke before. Not forgetting to FTP the custom pins to the same location as before too 🙂

    Once again, thank you Steven.

    Plugin Author stevenellis


    Greet, glad to hear the backup worked! 🙂

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Easy2Map Version 1.1.6 Site Loading Issues’ is closed to new replies.