WordPress.org

Forums

Easy Modal
[resolved] Easy Modal not working all of a sudden (10 posts)

  1. iconoclastix
    Member
    Posted 1 year ago #

    Hi, I was using the Easy Modal plugin for awhile and it was working perfectly...but recently (in the past 2 weeks approximately) it has stopped working. I'm assuming it is to do with a recent update, as it was working fine before and now the modal windows won't load.

    The plugin is the most up-to-date version. Here's the page URL where my modal boxes are: http://forms.nipissingu.ca/self-identification-form/ (the modal box links are about halfway down the page on the right side and are labelled as "documentation")

    I checked the error console but couldn't see anything pertaining to the modal boxes/plugin. Any help would be greatly appreciated!

    http://wordpress.org/plugins/easy-modal/

  2. mjefferson96
    Member
    Posted 1 year ago #

    Me too, I was developing a site http://www.andieday.com and it was working fine, then it just stopped working. And now I've launched the site and my modals are not working. Any ETA on a fix?

  3. danieliser
    Member
    Plugin Author

    Posted 1 year ago #

    It seems the modals are not being loaded to the page. The latest version ads the ability to load the modals either SiteWide or on a per page basis.

    I thought we had it working to when updating to this version set all modals as sitewide but it has become apparent that it in fact didnt.

    Simply edit the modals and change the Site Wide option to yes, or if you only need them on 1 or 2 pages then leave them set to no.
    Then edit the page you want them on and you should see a selectbox to choose which modals are loaded.

    Choose one of these options and try it again. Let me know if you have any further issues.

  4. iconoclastix
    Member
    Posted 1 year ago #

    Hi,

    I actually tried both methods, but neither seemed to fix the problem.

    First I tried setting them ALL to site-wide = YES, but they still didn't work. Next I tried setting them all back to NO, and selecting them while on the "Edit Page" screen, but even after clearing my browser cache the modals still aren't working (I tried in Firefox and Chrome).

    At the moment I've set all of the modal windows back to set-wide = YES (again, still not working though)

    Any ideas why?

  5. danieliser
    Member
    Plugin Author

    Posted 1 year ago #

    Hmm.. I see the modals being loaded in the footer properly. If you can send me a temporary account to try and work out the problem quickly for you email it to danieliser @ wizardinternetsolutions.com

    Do you have any JS being called on click for those links?

  6. iconoclastix
    Member
    Posted 1 year ago #

    Hi, I sent you an email with some credentials as well as some extra background. Thanks for any help!

  7. danieliser
    Member
    Plugin Author

    Posted 1 year ago #

    Check your email fix should be working for you.

  8. iconoclastix
    Member
    Posted 1 year ago #

    Thanks for the fix!

    In case anyone else has the same problem, I was able to get the modals working again by removing this bit from the modal links:

    href="#"

    In other words, my modal links look like this:

    <a class="eModal-1">(documentation)</a>

    Thanks a lot to the author for helping me solve this.

  9. danieliser
    Member
    Plugin Author

    Posted 1 year ago #

    Your welcome. I am still looking to find the reason why these didnt work to begin with. Please take a few minutes to rate and review the plugin here http://wordpress.org/support/view/plugin-reviews/easy-modal

  10. Bill Gilmore
    Member
    Posted 1 year ago #

    Changing the Site Wide option to yes worked for me.
    thanks danieliser

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic