Support » Plugin: Easy FancyBox » Easy Fancybox don't work after updated to 1.5.0 v

Viewing 7 replies - 1 through 7 (of 7 total)
  • Same problem here. After updated to WP 3.5.2, Easy Fancy Box has stoped working. I wonder how we could fix this issue.

    Plugin Author RavanH


    Hi sitemakiyato, there are several thing going wrong:

    1. your theme seems to be loading a very old jQuery version on its own on top of the one included with WordPress. I see this just before the closing </head> tag in your page source code:

    <script type="text/javascript" src=""></script>

    This needs to be removed. If you want to use a Google hosted jQuery, then use the plugin Use Google Libraries

    2. your theme is missing its footer.php (probably) or somehting is preventing proper execution. This causes the page source code to be incomplete and missing the proper script files for FancyBox and probably other stuff to run. You need to find out why this is happening.

    A look in the error log files might help. Or disable all plugins, check if the footer is properly working then, and then enable each plugin one by one until you find out which one is causing this…

    Hi, RavanH. Thank you, some things have cleared up.
    About point 2. I had some code that hampered the work of the theme.
    I removed it and footer.php work now.
    About point 1. I removed this tag:
    <script type="text/javascript" src=""></script>
    Installed this plugin, but Easy Fancybox still doesn’t work.
    I know it’s because my theme is old. I set another theme and Easy Fancybox worked perfectly.
    But could you help me?

    Plugin Author RavanH


    Open the theme file script.js in the WordPress theme editor and find this part near the bottom of the file:

    /* Botton uptotop*/

    Now just add a $ to the jQuery(function(){ so that line looks like this:


    Save and revisit your site after clearing the browser cache.

    Thanks a lot. It’s work. I like your plugin, it’s very useful.

    Hi RavanH,

    I followed every instruction given on all those fancybox-wont-work-after-update topics but still cant get it running.

    I am using Quform plugin where opening a form in fancybox works well. My site is here

    I couldnt find the right to do… Do you have any hints?

    Plugin Author RavanH


    Hi mainroller,

    The issue is the same, the cause may be different. In your page source code I see:

    <script type='text/javascript' src=''></script>
    <script type='text/javascript'>try{jQuery.noConflict();}catch(e){};</script>

    which means you are using an older version of the jQuery library. You need to find out why your site it using this older version. It might be because of a plugin, or your theme… And then, you need to ‘fix’ that.

    Alternatively (and maybe easier) you can just revert to the previous version of my plugin which is compatible with jQuery 1.6.x and older. Download and upload via FTP, overwriting the current plugin files. And don’t forget to NOT upgrade unless you are sure your site is using a more current version of jQuery like the one included with WordPress…

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Easy Fancybox don't work after updated to 1.5.0 v’ is closed to new replies.