WordPress.org

Support

Support » Plugins and Hacks » Easy FancyBox » [Resolved] Easy FancyBox doesn't work after upgrading WP & plugin

[Resolved] Easy FancyBox doesn't work after upgrading WP & plugin

  • I had been running a photography website in a 2.x version of WordPress using a older version of Easy FancyBox. Had worked great, but I had the notification to upgrade both WP & the plugin. After upgrading both to the latest installments, linked thumbnails no longer opened in Fancybox but directly to image URL. Please help!

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author RavanH

    @ravanh

    Got a link?

    If not, please check the FancyBox settings carefully and resave them. Something might have gone haywire during the upgrade. You might need to adjust the setting Selector(s) to be compatible with you theme.

    http://www.jeffblettner.com/photography/

    I’m using AutoFocus+ 1.3 as my theme. I’ve been playing with the plugin settings and having no luck. Here’s a screenshot of my current settings.

    Plugin Author RavanH

    @ravanh

    Looking at the pages, I see two problems:

    1. I get the error Uncaught exception: TypeError: Cannot convert 'a.attributes' to object which seems caused by a conflict between two theme js files that are loaded together:

    <script type='text/javascript' src='http://www.jeffblettner.com/photography/wp-content/themes/autofocusplus/js/jquery.hotkeys-0.7.9.min.js?ver=20100329'></script>
    <script type='text/javascript' src='http://www.jeffblettner.com/photography/wp-content/themes/autofocusplus/js/afscripts.js?ver=20100329'></script>

    No idea what theme option is responsible but if you can make the theme load just ONE of them instead of both, the error is gone…

    2. There is a problem with my plugins way of processing the FancyBox CSS and the fact that your WP site is installed in a subdir. I’ll look in to that and get back to you on it ASAP. Meanwhile, switching off the auto-trigger option for images should make the script work (but without automaticaly opening the first image of course)…

    I deleted the first javascript file (there’s another “hotkeys” js file in the generic wordpress files) and that did the trick! Thanks.

    Plugin Author RavanH

    @ravanh

    Excellent!

    I have not seen the CSS problem anymore so maybe my second conclusion was wrong… Glad to see it work 🙂

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘[Resolved] Easy FancyBox doesn't work after upgrading WP & plugin’ is closed to new replies.
Skip to toolbar