Support » Plugins » Easy CSV Importer WYSIWYG Editor Requires WP 3.2

  • Hello again,

    A lot of people treating an issue with the WYSIWYG editor as a bug, as in telling me the plugin is totally broken because of this one issue, which it is not really. It is just a change in WordPress and PHP. The specific issue is not being able to switch between the design and html windows of the WYSIWYG editor on the Easy CSV Importer Design page.

    The fix…

    Update your WordPress installation if you don’t yet have 3.2 and it should work fine.

    Users of the premium edition will not get refunds for this issue as being request by someone, making me write this! 🙂

    Many users of the free edition have the same complaint. I’m advising everyone to check all the details of plugins they are installing. Plugin profiles show the minimum WordPress version required, as does ECI.

    Thank you everyone and I hope you enjoy using ECI.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Moderator Ipstenu (Mika Epstein)


    Lead Plugin Wrangler

    WebTechGlobal – You need to code something into your plugin to not be able to ACTIVATE if they’re using pre 3.2 then, just to CYA.

    // First we check to make sure you meet the requirements
    global $wp_version;
    $exit_msg_ver = 'Sorry, but this plugin is no longer supported on pre-3.0 WordPress installs.';
    if (version_compare($wp_version,"2.9","<")) { exit($exit_msg_ver); }

    For example.

    Yes sure I am going to but I’m deep into upgrading it in other ways right now and not getting the chance.

    I’m going to create a standard function to handle a version message for all my plugins so this issue is dealt with without fuss in future.

    That got me thinking, why doesn’t WordPress just do that?! WordPress already reads the version, just has to warn the user that they are installing a plugin older than their version of WordPress against the authors recommendation.

    Is that something a Half-Elf Support Rogue could put forward?!

    Oh and thank you for replying Ipstenu the Half-Elf.



    Forum Moderator

    why doesn’t WordPress just do that?

    Because this assumes that plugin authors update their plugin’s readme for every WP update. That’s simply not the case – often because the current plugin works just fine and doesn’t need updating.

    Sorry I did mean for the author to apply something that triggers it.

    Even a value following the version number…

    6.3.9 (3.2.1)

    The existence of brackets triggering WordPress to display a message telling the user, the author recommends 3.2.1 or higher.

    That idea is just off the top of my head. I know there are areas of WordPress that would need to be made to remove the brackets but when is something good ever easy huh 🙂



    Forum Moderator

    I did mean for the author to apply something that triggers it.

    But that would still mean that plugin authors would have to update their readme for every WP update – even if the plugin itself doesn’t need updating. Not sure that would go down well with users who tend to complain if plugins are upgraded too frequently. *sigh*

    To cite an example, I use an excellent backup plugin that is only “officially” documented to be compatible up to WP 2.5. It still works just fine with 3.2.1. So that would set off warnings all over the place for no good reason. Or the author would have to keep updating his readme – again for no good reason.

    I’m not trying to knock your idea. It’s something that’s been mentioned before. And in theory, it’s a good idea. It’s just that it may not be realistic in practice.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Easy CSV Importer WYSIWYG Editor Requires WP 3.2’ is closed to new replies.