Support » Plugins » [Easy Comment Uploads] – permissions problem

  • I can’t seem to get the plugin to work. I changed the default location for the files and I got a message that permissions for the folder are not set properly. So I changed them to suggested level and even beyond. At that point when I try to upload file I don’t get any messages but the file is not attached and the form resets itself.

    I also tried default location and I get the same result – no error message, file is not attached and the part of comment form where you upload te flie resets itself.

    Even more interesting, is the fact that when I check the destination folder on my server, the file is there.

    Any sugesstions?

Viewing 8 replies - 1 through 8 (of 8 total)
  • Hi,
    could you check whether this occurs when using the default WordPress theme. It sounds like by changing the permissions, you have fixed your first problem and now are experiencing an unrelated, theme dependant, error. Please could you also let me know which theme you are using, and any other comment related plugins so I can investigate further.

    Hi and thanks for fast replay!

    Here’s what I did:
    – I use Comment Validation plugin and Akismet. I deactivated Comment Validation – still unable to upload images in comments
    – I activated my theme on test installation and uploading images in comments worked
    – I activated TwentyTen on my production site and plugin didn’t work

    If it helps you can check out my website, it’s:

    Maybe the reason is one of my other plugins – WP Subdomains? But it’s crucial for me and I don’t want to deactivate it…

    In the meantime I’m gonna deactivate my other plugins and see what happens.

    Ok, it’s WP Subdomains fault. When I disabled it your plugin worked.

    Although, pictures didn’t show… after upload the path at the bottom was ok but the image wasn’t displayed, and after submitting comment instead of image there was a “broken/missing image” icon. When I click the icon the image opens in new tab.

    Still it’s no good to me, because as i mentioned before, I need to use WP Subdomains.

    Ok, in that case I will test the plugin with WP Subdomains and attempt to fix it in the next version. The images not displaying is probably due to a problem with the timthumb script used to generate thumbnails; if you just right click on the image and select ‘open image in new tab’ (or your browser’s equivalent message), you should be able to resolve this fairly easily.

    In that case I look forward to the next version of Easy Comment Uploads 🙂 Do you have a timeframe for that in mind?

    A few weeks perhaps; I am hoping to finish it before I head to uni.

    Hi! I see that You updated the plugin. Did You have any luck with making it compatibile with WP Subdomains?

    Sorry, I have been somewhat busy so that has been delayed till the next version.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘[Easy Comment Uploads] – permissions problem’ is closed to new replies.