Support » Plugin: Easing Slider » Easing slider has white background between slides

  • Resolved haloheathr

    (@haloheathr)



    After updating the Easing slider plugin, there is now a flash of white between slides — so instead of fading directly into the next slide, it seems to fade quickly to white and then to the next slide. It gives this flashing effect that is very unappealing. I’ve tried experimenting with my stylesheet to remove what I’m assuming is a white background, but have not had any luck yet. This was not a problem before the update. Is anyone else having the same problem?

    Here is a link to my site: https://laumc.org/
    I currently only have one image in my slideshow, but you can still see the white flashing. There is also a white thin bar directly under the slideshow, which is some kind of padding or margin that wasn’t there before either.

    https://wordpress.org/plugins/easing-slider/

Viewing 4 replies - 1 through 4 (of 4 total)
  • Update: I was able to remove the white background by adding this code to my stylesheet:

    .easingslider-slide{background-color:transparent !important;}

    BUT it is still flashing. Now it just shows the site’s background briefly in between slides instead of solid white, which is an improvement but still not ideal. It’s particularly noticeable because I only have one slide currently. The blinking or flashing didn’t occur before when there was only one slide. https://laumc.org/

    Plugin Author MatthewRuddy

    (@matthewruddy)

    Hi @haloheathr, this is a caveat to the new lazy loading functionality we’ve implemented. This feature has extremely sped up Easing Slider loading times, but requires both the current and next slide to be faded in and out simultaneously. This causes a brief gap between fade transitions that you’re seeing as a slight “flash”.

    Sadly it’s unavoidable. You’ll notice the same with other sliders also using Lazy Loading. I’ll see for future if I can find any improvements.

    Thanks so much for your quick response Matthew! I understand what you’re saying. Just out of curiosity, is there a way to temporarily disable the Lazy Loading during those times when I only have one slide showing, so that there isn’t the flashing? It’s not a big deal at all when there are multiple slides, which is usually the case for a slider! But every once in a while my client only has one slide.

    I just tried unchecking the Enable Lazy Loading option under Preloading tab for my slider’s settings. Doing so didn’t get rid of the flashing, so I’m guessing there isn’t a way to temporarily disable it. Just thought I’d ask though.

    Thanks for all your great work on this plugin!

    Plugin Author MatthewRuddy

    (@matthewruddy)

    I’ll see if I can improve it in future versions. May be possible to stop the flashing when only one slide is added for sure. Otherwise, sadly no way to get rid of the flash!

    Sorry for not having a solution! And thanks, great to hear praise 🙂 Really do appreciate it!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Easing slider has white background between slides’ is closed to new replies.