WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Easing Slider for Homepage Only Not Working…

[Resolved] Easing Slider for Homepage Only Not Working…

  • mhutchins
    Member

    @mhutchins

    Hello,

    I’m trying to insert the easing slider for my homepage header only on the twentyeleven theme. I have moved the navigation above the header image(s) and have the easing header on there, but the images are off to the right of the body in Firefox. The sliding image is under the nav in what looks like the right location in Chrome, but the nav buttons won’t work. It’s seems to be working fairly close in IE, minus the bottom of the first image doesn’t fade it…not a huge deal, but would be nice if it was uniform. Also, I’m not quite sure how to code it to only have the sliding header on the homepage. I’m not the programming guru, so any and all help would be greatly appreciated!

    The current url is http://www.hutchmd.com/reeders

    Thanks,
    m@

    http://wordpress.org/extend/plugins/easing-slider/

Viewing 15 replies - 1 through 15 (of 20 total)
  • Plugin Author MatthewRuddy
    Participant

    @matthewruddy

    Hi. It appears to be caused by the way you’ve achieved the positioning of the navigation. It doesn’t appear to be rendering the same in all browsers.

    I think you’ll need to find a new way to achieve the same positioning. Also make sure to put the floated elements inside clearfix’d divs, making sure everything plays nicely.

    As it is more of a theme styling issue, I can’t give much more advice on how to fix what is occurring. It isn’t directly related to the slideshow itself, just the way it is getting positioned relative to the other page elements above it. Sorry about that.

    mhutchins
    Member

    @mhutchins

    Thanks for the quick response. I’ll look into fixing my styles…I’m still at the “hacker” level in the coding world. Do you think you can point me in the right direction of just having the sliding header on the homepage?

    Thanks again!

    Plugin Author MatthewRuddy
    Participant

    @matthewruddy

    Haha, don’t worry about it. No harm doing some hacking, great way to learn.

    To display the slideshow on just the home page, try using this in your theme file to display the slideshow:

    <?php
    if ( is_home() && function_exists('easing_slider') ) {
        easing_slider();
    }
    ?>

    Alternatively, if that doesn’t work, you can change the is_home() to is_front_page().

    wkcheung65
    Member

    @wkcheung65

    Thnak you MatthewRuddy, the plugin is very user friendly and simple. Amazing!!!!!

    Plugin Author MatthewRuddy
    Participant

    @matthewruddy

    No problem at all 🙂

    Musicalman
    Participant

    @musicalman

    Thank you for this code Matthew; works a treat 🙂

    Plugin Author MatthewRuddy
    Participant

    @matthewruddy

    Great to hear 🙂

    cliffywiffy
    Member

    @cliffywiffy

    Sorry to hijack, but in which theme file should the code above go in to?

    Thanks

    Plugin Author MatthewRuddy
    Participant

    @matthewruddy

    It depends on your theme and where you wish to display the slideshow. Not much more of an answer I can give than that. Trial and error is probably the best way to find out!

    cliffywiffy
    Member

    @cliffywiffy

    I want the slider on the home page only…any clue as to which theme file i should be looking for (and which to avoid)

    Thanks

    Plugin Author MatthewRuddy
    Participant

    @matthewruddy

    Again, this completely depends on your theme. Try the index.php files, header.php file or page.php file. If none of those, I really don’t know. Sorry.

    cliffywiffy
    Member

    @cliffywiffy

    No need to apologise Matthew…I understand.

    Plugin Author MatthewRuddy
    Participant

    @matthewruddy

    Hope you can get it working as intended 🙂 Good luck!

    Hi Matthew! I have trouble with your slider in iexplorer 9. I have the Slider in a page like this [easingslider]
    I works just fine in any other browser, but wont work in ie9… please help 🙂

    I see now it is in conflict with my lightbox plugins: oth of them. any suggestions to how to fix it?

Viewing 15 replies - 1 through 15 (of 20 total)
  • The topic ‘[Resolved] Easing Slider for Homepage Only Not Working…’ is closed to new replies.