Support » Networking WordPress » Each alias (subdomain) uploads http not https

  • Hi I have to manually change the url in phpmyadmin after each site added. I am using the method of site.website.com, theme.website.com etc. and add a new site as an alias.
    I disabled the multisite in wp-config and checked the main site has https of which it does.
    But the uploads for the alias are always http not https and I have to manually update the site options in phpmyadmin.

    Is there a way to make this load as https automatically please.
    The host also added a wildcard SSL for the main site but it doesn’t seem to work for the uploads.

    Thanks

Viewing 1 replies (of 1 total)
  • Moderator bcworkz

    (@bcworkz)

    If the SSL cert is not being applied to uploads, then upload URLs will all be http. The upload URL protocol is determined from is_ssl(), which looks at your server’s configuration. The SSL configuration has to be correct for is_ssl() to return true and for uploads to automatically be https.

    You can override this behavior through the ‘set_url_scheme’ filter, but if you use https URLs without the appropriate SSL cert, browsers will either refuse to fetch the file, or throw an insecure content warning.

    Your best option is to get SSL working correctly, then the WP URLs will reflect it.

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.