WordPress.org

Forums

Eaccelerator Cache Eats My Disk Usage (8 posts)

  1. ryonn
    Member
    Posted 7 years ago #

    Hi all,

    I have a problem with my blog (WordPress powered)
    It makes daily cache files with huge size such as:

    username 45920 Feb 27 14:15 ./0/2/eaccelerator-5602.88090024
    username 90672 Feb 27 14:15 ./0/2/eaccelerator-5602.20190024
    username 108880 Feb 27 14:15 ./0/2/eaccelerator-5602.98090024
    username 304184 Feb 27 14:15 ./0/2/eaccelerator-5602.69090024
    username 337444 Feb 27 14:15 ./0/2/eaccelerator-5602.19090024
    username 54048 Feb 27 14:15 ./0/2/eaccelerator-5602.89090024
    username 227396 Feb 27 14:15 ./0/2/eaccelerator-5602.79090024
    username 39516 Feb 27 14:15 ./0/2/eaccelerator-5602.29090024
    username 100252 Feb 27 14:15 ./0/2/eaccelerator-5602.10190024

    It is made in the _root/var/cache/

    Enough to make my disc usage cache color in cpanel to RED everyday.
    I have no idea how and what makes the cache files.
    Things that I have done:

    - Downloaded all of the files, and run 'grep eaccelerator' to find the word eaccelerator inside all of the files.
    None Found

    - Deleting each files containing the word 'cache' except wp-includes/cache.php

    - Contacting admin of webhosting. They tell me that it's not from them, but it's from me. I believe them since my other websites hosted at them do not have this problem.

    Is there anyone ever experiencing this problem?
    Anyone knows the solution?
    What could possibly make this cache file?
    How to disable this?

    This drives me crazy already.. almost 2 months researching this.

    Please help.

    Kind regard
    R

  2. cstina
    Member
    Posted 7 years ago #

    This sounds like your wp-cron.php file. If you have Cpanel, go to Cron Jobs and set up a Job for wp-cron.php --- and tell that file how often and when to hit the server. You might want it to run just once a day, in the wee hours of the morning... unless you post several times a day. Then, you might want to schedule the Job for more x per day.

    If you don't know how to set up a Cron Job, your Host should be able to tell you how... it's pretty straight forward.

    Some people, unknowningly, have wp-cron.php setup to call the server almost constantly... which can send the alarm bells ringing to a Host (due to CPU Usage).

    If you do a Search on here for "wp-cron.php" "cache" ... you'll see what I mean. I had the same problem and all I could do was schedule a Cron Job on a lighter schedule. It worked like a charm.

    .

  3. ryonn
    Member
    Posted 7 years ago #

    Well, I have tried using Cron Job:
    1. Open Cron Job
    2. Type wp-cron.php
    3. Choose 2 days

    But it seems futile

    username 21208 Feb 28 05:00 ./2/2/eaccelerator-5602.12358194
    username 588 Feb 28 05:00 ./2/2/eaccelerator-5602.72358194
    username 39516 Feb 28 04:59 ./9/1/eaccelerator-5602.27158194
    username 227396 Feb 28 04:59 ./9/1/eaccelerator-5602.57158194
    username 88840 Feb 28 04:59 ./9/1/eaccelerator-5602.08158194
    username 54048 Feb 28 04:59 ./9/1/eaccelerator-5602.47158194
    username 278940 Feb 28 04:59 ./9/1/eaccelerator-5602.77158194
    username 98620 Feb 28 04:59 ./9/1/eaccelerator-5602.18158194
    username 90672 Feb 28 04:59 ./9/1/eaccelerator-5602.97158194
    username 112732 Feb 28 04:59 ./9/1/eaccelerator-5602.17158194
    username 45672 Feb 28 11:23 ./9/1/eaccelerator-5602.07158194
    username 16528 Feb 28 05:00 ./9/1/eaccelerator-5602.28158194

    I cannot delete these files since it's hidden from me. Only Hosting admin can delete this. Thus, if I set cron thingy to daily, then how can I delete the stuffs?

  4. cstina
    Member
    Posted 7 years ago #

    Eaccelerator (as seen in your links above) is a Plugin. You need to disable that Plugin and see what happens. If you're using Eaccelerator, then you're caching your php files in blocks (COMPILING them before caching). It's a good plugin to help process your php scripts, but if you're running a good Cron Job, then you don't need BOTH eaccelerator and a nicely scheduled wp-cron.php running at the same time.

    So, you don't need to delete that plugin... you need to deactivate that plugin through your WP control panel.

    .

  5. ryonn
    Member
    Posted 7 years ago #

    hi cstina,

    The problem is I dont have eaccelerator plugin at all.

    Akismet
    GoogleSitemap
    Simple Tags
    WP Ban
    Related Posts
    WordPress Stats
    Full Text Feed

    Those are the only plugins that I have.
    Maybe one of them has the eaccelerator?

    Thanks cstina for helping.
    Really appreciate it.
    I hope you dont mind helping me til this is solved.

    This drives me crazy indeed ><

  6. ryonn
    Member
    Posted 7 years ago #

    Hello
    Could someone please help me?

  7. Ryonn,

    You might want to switch to another provider if eAccelerator is using up all your disk quota.

    This is not a WordPress module, it's a PHP module that is part of your installation. If you can control the php.ini settings then try setting this in your php.ini:

    eaccelerator.shm_only = "1"

    Restart your Apache and delete your eAccelerator disk cache.

    You can check the settings by creating a file and put phpinfo() in it.

    For example create phpinfo.php (original name) and copy this into it and save it:

    <? phpinfo(); >

    Put that file in your wordpress directory and load it up in your browser.

    http://youeblog-url-here.com/phpinfo.php

    Scroll down or search for the eAccelerator table on that page and look at some items.

    In that table look for "Memory Allocated". Keep an eye on that number. Also look for "Cached Scripts" and also keep an eye on that number.

    Last item is the settings "eaccelerator.shm_only". If that's set to 1 then the disk caching should not be happening anymore.

    If you can't change the php.ini settings (or have no idea what I'm talking about...) then talk to your provider and ask them to set this for you.

  8. cstina
    Member
    Posted 7 years ago #

    Ryonn,

    Okay, if it's a Host thing, try this.

    Step 1) Go to the Cpanel/Control Panel for you domain.

    Step 2) Look in "public_html" (sometimes called .htdocs) for the ".htaccess" file.

    Step 3) Open .htaccess to Edit it (save a backup copy first, just in case).

    Step 3) In the .htaccess file, look for these 2 lines:

    php_flag eaccelerator.enable 1
    php_flag eaccelerator.optimizer 1

    Option 1) If you DO see that code ^ ^ then change it to this:

    php_flag eaccelerator.enable 0
    php_flag eaccelerator.optimizer 0

    Option 2) If you do NOT see that code, then ADD those 2 lines, like this:

    php_flag eaccelerator.enable 0
    php_flag eaccelerator.optimizer 0

    That should work... it's how I have mine configured, exactly.

    More info is here:
    http://www.eaccelerator.net/

    That thing does come packaged as a wordpress plugin here:
    http://neosmart.net/blog/2007/xcache-and-eaccelerator-wp-plugins-updated/

    .

Topic Closed

This topic has been closed to new replies.

About this Topic