Support » Plugin: Post SMTP Mailer/Email Log » E_ERROR after updating PHP from 7.2 to 7.4

  • Resolved SietseB

    (@sietseb)


    Hello,

    On two sites where I updated the PHP version from 7.2 to 7.4 I get an error from WordPress.

    Do you know what causes this?

    Thanks in advance!

    This is the error message:

    Error details
    ===========
    An error of type E_ERROR was caused on line number 329 of the file /home/alfasigma/domains/e-al.nl/public_html/wp-content/plugins/post-smtp/Postman/Postman-Mail/PostmanSmtpModuleTransport.php. Error: Uncaught Error: Class ‘PostmanAdminController’ not found in /home/alfasigma/domains/e-al.nl/public_html/wp-content/plugins/post-smtp/Postman/Postman-Mail/PostmanSmtpModuleTransport.php:329
    Stack trace:
    # 0 /home/alfasigma/domains/e-al.nl/public_html/wp-content/plugins/post-smtp/Postman/Postman-Mail/PostmanSmtpModuleTransport.php(294): PostmanSmtpModuleTransport-> addSettings ()
    # 1 /home/alfasigma/domains/e-al.nl/public_html/wp-includes/class-wp-hook.php(292): PostmanSmtpModuleTransport-> on_admin_init (”)
    # 2 /home/alfasigma/domains/e-al.nl/public_html/wp-includes/class-wp-hook.php(316): WP_Hook-> apply_filters (NULL, Array)
    # 3 /home/alfasigma/domains/e-al.nl/public_html/wp-includes/plugin.php(484): WP_Hook-> do_action (Array)
    # 4 /home/alfasigma/domains/e-al.nl/public_html/wp-content/plugins/iwp-client/core.class.php(249): do_action (‘admin_init’)
    # 5 /home/alfasigma/domains/e-al.nl/public_html/wp-includes/class-wp-hook.php(292): IWP_MMB_Core-> admin_wp_loaded_iwp (”)
    # 6 /home/alfasigma/domains/e-al.nl/public_html/wp-inc

    The page I need help with: [log in to see the link]

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Tim

    (@tneville)

    Hi @sietseb,

    Some updates to the plugin code need to be made to fully support PHP 7.4, at the moment we don’t have a timescale for when this will be done. Sorry about that.

    Kind Regards,
    Tim

    Hi – Any more news on this?

    I see the same error using PHP 7.3. Presumably Post SMTP Mailer should support PHP version 7.3 by now?

    Plugin Support Tim

    (@tneville)

    Escalating to the developer for comment. @yehudah

    Kind Regards,
    Tim

    Client also just got this error with PHP 7.3 (An error of type E_ERROR was caused in line 329).

    WordPress version 5.8
    Current theme: Thrive Theme Builder (version 2.8.2)
    Current plugin: Post SMTP (version 2.0.23)
    PHP version 7.3.29-1+ubuntu18.04.1+deb.sury.org+1

    Error Details
    =============
    An error of type E_ERROR was caused in line 329 of the file
    /*****/wp-content/plugins/post-smtp/Postman/Postman-Mail/PostmanSmtpModuleTransport.php.
    Error message: Uncaught Error: Class ‘PostmanAdminController’ not
    found in /*****/wp-content/plugins/post-smtp/Postman/Postman-Mail/PostmanSmtpModuleTransport.php:329
    Stack trace:
    #0 /*****/wp-content/plugins/post-smtp/Postman/Postman-Mail/PostmanSmtpModuleTransport.php(294):
    PostmanSmtpModuleTransport->addSettings()
    #1 /*****/wp-includes/class-wp-hook.php(303):
    PostmanSmtpModuleTransport->on_admin_init(”)
    #2 /*****/wp-includes/class-wp-hook.php(327):
    WP_Hook->apply_filters(NULL, Array)
    #3 /*****/wp-includes/plugin.php(470):
    WP_Hook->do_action(Array)
    #4 /*****/wp-admin/admin-ajax.php(45):
    do_action(‘admin_init’)
    #5 {main}
    thrown`

Viewing 4 replies - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.