Support » Plugin: WooCommerce Admin » E_COMPILE_ERROR

  • Resolved rhcburg

    (@rhcburg)


    Hi,
    whenever I update any plugin, I get this error reported by word fence:

    Error Details
    =============
    An error of type E_COMPILE_ERROR was caused in line 98 of the file /wp-content/plugins/woocommerce-admin/includes/class-wc-admin-api-init.php. Error message: require_once(): Failed opening required ‘wp-content/plugins/woocommerce-admin/includes/api/class-wc-admin-rest-admin-notes-controller.php’ (include_path=’.:/usr/local/php73/lib/php’)

    Thanks
    Rich

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Ron Rennick

    (@wpmuguru)

    Which version of WC Admin do you have installed?

    I’m getting the same error on the latest version and now I can’t access my site at all.

    Error Details
    =============
    An error of type E_COMPILE_ERROR was caused in line 98 of the file /home/strike9/public_html/moreheadspeedworks.com/wp-content/plugins/woocommerce-admin/includes/class-wc-admin-api-init.php. Error message: require_once(): Failed opening required ‘/home/strike9/public_html/moreheadspeedworks.com/wp-content/plugins/woocommerce-admin/includes/api/class-wc-admin-rest-admin-notes-controller.php’ (include_path=’.:/opt/cpanel/ea-php72/root/usr/share/pear’)

    Thread Starter rhcburg

    (@rhcburg)

    Hi,sorry for the delay in replying:

    Version: 0.17.0

    MAny thanks
    Rich

    Plugin Author Ron Rennick

    (@wpmuguru)

    Version: 0.17.0

    If possible, delete the plugin using you hosting control panel or FTP & upload a new copy using the same method. The plugin/theme/update installer in WP sometimes misses replacing a file.

    Thread Starter rhcburg

    (@rhcburg)

    HiRon
    ok – have reinstalled the 0.17.0 from the website https://wordpress.org/plugins/woocommerce-admin/ and activated it. Will now wait for the next update for a plugin to appear to test it.

    many thanks
    Rich

    • This reply was modified 2 years, 5 months ago by rhcburg.

    I received the same error yesterday when updating a client site to Woocommerce Admin version 0.17.0. It does not appear to have broken anything, as I can still access the website and dashboard. Error received via email.

    
    Error Details
    =============
    An error of type E_COMPILE_ERROR was caused in line 98 of the file
    /home/client_site/public_html/wp-content/plugins/woocommerce-admin/includes/class-wc-admin-api-init.php.
    Error message: require_once(): Failed opening required
    '/home/client_site/public_html/wp-content/plugins/woocommerce-admin/includes/api/class-wc-admin-rest-admin-notes-controller.php'
    (include_path='.:/usr/local/php71/pear')
    
    Thread Starter rhcburg

    (@rhcburg)

    Hi,
    even with 0.18.0 still getting the message:

    Warning: call_user_func_array() expects parameter 1 to be a valid callback, function ‘update’ not found or invalid function name in /home/wrens/www/www/wp-includes/class-wp-hook.php on line 286

    Thanks
    Rich

    Plugin Support Doug – a11n

    (@dougaitken)

    Automattic Happiness Engineer

    Hi all,

    I’m going to mark this as “Resolved”.

    If you are running into this issue, please start a new thread confirm the exact version of WooCommerce Admin and whether you installed via WordPress plugin directory or via manual zip installation.

    Please also confirm whether deleting the plugin and uploading and activating manually resolved this.

    Thanks,

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘E_COMPILE_ERROR’ is closed to new replies.