Support » Plugin: All in One SEO - Best WordPress SEO Plugin - Easily Improve Your SEO Rankings » Dynamic sitemap generation does not appear to be using the correct rewrite rules

  • Resolved cheepnis

    (@cheepnis)


    Receiving this error when trying to enable dynamic sitemaps:

    “Dynamic sitemap generation does not appear to be using the correct rewrite rules; please disable any other sitemap plugins or functionality on your site and reset your permalinks.”

    I removed Yoast to install AIO, but I’m getting this error. I don’t know where or what I need to do to correct this. Any help. In the meantime, I’m using static sitemap.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Plugin Support wpsmort

    (@wpsmort)

    @cheepnis This message is output when you haven’t set up pretty permalinks. Go to Settings > Permalinks in WordPress and see if you’ve changed from the default Plain options to one of the other options. We recommend Post name.

    Thread Starter cheepnis

    (@cheepnis)

    I was using Day and Name, not the plain setting. I changed it to Postname, but I got the same results. Did Yoast leave any junk that might be interfering? I already removed the two database tables that were created by Yoast.

    Static sitemaps are generated correctly. This only seems to affect dynamic setting.

    Plugin Support wpsmort

    (@wpsmort)

    Are you running Apache or NGINX on your server?

    Thread Starter cheepnis

    (@cheepnis)

    Apache

    Plugin Support wpsmort

    (@wpsmort)

    @cheepnis Please contact us here https://semperplugins.com/contact/ so we can help you further. Please choose Plugin support and paste the URL of this forum post in the License Key field.

    ukeaglesfan

    (@ukeaglesfan)

    I have the same issue, how was this resolved?

    Plugin Support wpsmort

    (@wpsmort)

    @ukeaglesfan What is the URL for your XML Sitemap and is your server running NGINX or Apache. Also, is this a single install of WordPress or a Multisite Network?

    ukeaglesfan

    (@ukeaglesfan)

    @wpsmort URL is https://www.goalprofits.com/sitemap.xml

    It’s a single install, I believe running Apache.

    • This reply was modified 10 months ago by ukeaglesfan.
    Plugin Support wpsmort

    (@wpsmort)

    @ukeaglesfan Can you go to All in One SEO > XML Sitemap and click the Update Options button and see if the notice goes away.

    ukeaglesfan

    (@ukeaglesfan)

    @wpsmort I see an “Update Sitemap” button but not “Update Options”. Clicking it does not remove the error message. I also noticed that the sitemap URL goes to a 404 page.

    I have around a dozen WordPress sites across two servers and three of them have this issue.

    Plugin Support wpsmort

    (@wpsmort)

    @ukeaglesfan Please contact us at the link below so we can troubleshoot this further. Please select support as the reason for contact and paste the URL of this forum post in the License Key field:

    https://semperplugins.com/contact/

    Thread Starter cheepnis

    (@cheepnis)

    “I have the same issue, how was this resolved?”

    I resolved this by using a better plugin for this feature.

    Plugin Support wpsmort

    (@wpsmort)

    @cheepnis This was caused by the fact that the sitemap had been renamed in the database from the default sitemap.xml. If you have the same problem, just activate the Importer Exporter module in All in One SEO, export your settings only (not the post type data), open the file in a text editor and change this line:

    aiosp_sitemap_filename = ‘sitemap’

    Then import the settings and it’ll change the sitemap name back to the default of sitemap.xml

    bahram021

    (@bahram021)

    I have the same issue, how was this resolved?

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Dynamic sitemap generation does not appear to be using the correct rewrite rules’ is closed to new replies.