Support » Plugin: Pardot » Dynamic shortcode does not work

  • Hi!
    Just setup the plugin and authenticated but I can’t get the dynamic shortcode [pardot-dynamic-content id=""] to work. The “static” iframe shortcode [pardot-form id=""] works with the same ID.
    There’s no debugging information at all, no errors.. It just outputs an empty <noscript></noscript> (not even with the default content even if I set that in the shortcode directly).
    So I’m thinking that there’s three possibilities:
    1. I’m missing something that needs to be setup in the pardot admin
    2. The dynamic shortcode does not work on a local dev site because your service needs to ping back to the server (?)
    3. Something is broken in the plugin.

    Gladly accept any help in the matter!

    EDIT:
    I’ve also tried it with an ngrok URL just to test wether (2.) above is the culprit but it’s the same thing.. so I’m guessing the dev server isn’t the issue.

Viewing 1 replies (of 1 total)
  • Plugin Author Cliff Seal

    (@cliffseal)

    Hey @jonathandejong,

    I wasn’t able to replicate this on a fresh WordPress installation on a local development server. Make sure the value in your id parameter corresponds to the ID of your dynamic content in Pardot, and make sure you have set values on that dynamic content there as well.

    Let me know if you’re still not able to get this working.

Viewing 1 replies (of 1 total)
  • The topic ‘Dynamic shortcode does not work’ is closed to new replies.