Support » Plugin: Duplicator - WordPress Migration Plugin » Duplicator VS. Ninjafirewall

  • Resolved azazio

    (@azazio)


    There is a problem when using Duplicator with Ninja firewall installed – NinjaFirewall might kick in during the installation process when installing the package to the new site.

    A possible solution to the problem:

    1. Create your package and installer.php and download them.
    2. Unzip your package and comment out ninjafirewall. Possible places to look for: .htaccess, .users.ini, config.php
    3. When commenting out (watch out for using the appropriate character for it, ; for .users.ini, // for config.php and # for .htaccess) modify the absolute path of ninjafirewall as well to the path your site will be.
    4. Rezip the package to any name you wish (but first remove the original .zip from the directory)
    5. Upload the zip package and the installer to your server, do the install procedure.
    6. Uncomment ninjafirewall at all places. Maybe you need to restore your original .htaccess and modify it.
    7. If you meet with strange behavior, check if all the tables exists in the new database – if not that is not Duplicator’s of ninjafirewall’s problem, but maybe mysqls.

    If you decide to do the ninjafirewall uninstall/reinstall instead of the procedure above – don’t forget to save the settings/rules of ninjafirewall, you might need it to reinstall ninjafirewall at the new site.

    Regards:

    azazio

    • This topic was modified 3 weeks, 3 days ago by  azazio.
    • This topic was modified 3 weeks, 3 days ago by  azazio.
    • This topic was modified 3 weeks, 3 days ago by  azazio.
Viewing 2 replies - 1 through 2 (of 2 total)
  • I forgot to mention point 8:

    – modify the link in ninjafirewall.php to the new absolute address. ninjafirewall.php is at /wp-content/nfwlog/

    Plugin Author Cory Lamle

    (@corylamleorg)

    Thanks, @azazio, we have added a link on our FAQ to this page.

    Cheers~

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.