Support » Plugin: Duplicator » Duplicator- "Parse error: Syntax error"

  • Resolved dorearendil

    (@dorearendil)


    Hi there!

    Thanks for developing Duplicator, which looks like an awesome plugin.
    I just created my first package + install, on my localhost server (Mamp). This all seems to work fine if I launch the install locally.

    However, once everything is uploaded to my server and I access the install.php file, all I get is this error:

    Parse error: syntax error, unexpected T_STATIC, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /[...]/installer.php on line 182

    File permissions are OK, and safe mode is disabled. Anything else I should check?

    Cheers,
    D-

    http://wordpress.org/extend/plugins/duplicator/

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Cory Lamle

    (@corylamleorg)

    It probably has to do with the version of PHP on the server your trying to install. What version are you using? It should be version 5.2.17 or better…

    Indeed it should!
    Old server, was running under PHP4.

    Thanks for the quick support!

    (now I just need to buy access to an extra database on my server… Shame Duplicator has to erase all existing tables 🙁 )

    Plugin Author Cory Lamle

    (@corylamleorg)

    In future versions it may provide the ability to choose which tables to overwrite…. Right now its just a simple utility to migrate and move…

    JUST A “LOVE THIS PLUGIN” !! ATTA BOY !! Terrific time saver..and YES it’s always the PHP version slop… I tried to proactively change that but with all the files getting overwritten I guess it’s just an extra step..Peace
    D

    Plugin Author Cory Lamle

    (@corylamleorg)

    Thanks oblivius!

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Duplicator- "Parse error: Syntax error"’ is closed to new replies.