WordPress.org

Forums

Duplicator
[resolved] duplicator - "Create package set" button is not active (13 posts)

  1. bogastyle
    Member
    Posted 1 year ago #

    System check is fine - all checks are green.
    But can't create package because this button is not active?
    See Take a look at screenshot:
    screenshot

    http://wordpress.org/plugins/duplicator/

  2. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    Hey bogastyle,

    Thanks for the feedback! If you can give the developer version a try it may have your fixes for the issue your seeing. The very latest version (0.5.0) can be found by following these instructions:

    -> Browse to http://wordpress.org/extend/plugins/duplicator/developers/
    -> Look for the section "Other Versions"
    -> Click on "Development Version" and download the zip plugin file
    -> Uninstall your current version and install this one
    -> Note: This is a development line version so please test in your sandbox first to make sure you have no issues...

    Let me know if this solves your issue...

    Thanks

  3. bogastyle
    Member
    Posted 1 year ago #

    Thank You Sir,

    I installed development version direct on live site and it works.
    So I made package and every thing should be fine.

    If any other issues I'll keep You informed.

    I can move WordPress manually, but after I found your plugin I become lazy. :)

    Regards.

  4. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    No Problem... I think we all like lazy the best ;)

  5. malky
    Member
    Posted 1 year ago #

    I had the same problem and tried it and get an error on the scan.

    If I ignore it then I get an error on the build.

    Scan error is here

    Fatal error: Uncaught exception 'RuntimeException' with message 'DirectoryIterator::__construct(/home/homerspa/public_html/wp-content/plugins/facebook/social-plugins/widgets) [directoryiterator.--construct]: failed to open dir: Too many open files' in /home/homerspa/public_html/wp-content/plugins/duplicator/classes/package.archive.php:106 Stack trace: #0 /home/homerspa/public_html/wp-content/plugins/duplicator/classes/package.archive.php(106): DirectoryIterator->__construct('/home/homerspa/...') #1 /home/homerspa/public_html/wp-content/plugins/duplicator/classes/package.archive.php(112): DUP_Archive->runDirStats('/home/homerspa/...') #2 /home/homerspa/public_html/wp-content/plugins/duplicator/classes/package.archive.php(112): DUP_Archive->runDirStats('/home/homerspa/...') #3 /home/homerspa/public_html/wp-content/plugins/duplicator/classes/package.archive.php(112): DUP_Archive->runDirStats('/home/homerspa/...') #4 /home/homerspa/public_html/wp-content/plugins/duplicator/classes/p in /home/homerspa/public_html/wp-content/plugins/duplicator/classes/package.archive.php on line 106

  6. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    Hey Malky,

    If you would like to submit a help ticket, I can look closer at your setup...

    Thanks~

  7. bogastyle
    Member
    Posted 1 year ago #

    Hi

    I think to me the problem was because of hosting provider. I think they use old Apache. And Errors are turned off so I didn't saw any error message.

    First time I used Duplicator on my blog which is on more modern hosting. With cPanel and latest versions of Apache, MySQL and PHP.

    And as I expect there wasn't any problem with Duplicator.
    Maybe lifeinthegrid should test plugin on different servers for example different XAMPP versions. If have time.

    I still think that Duplicator is great plugin.
    Have a nice day.

  8. Cory Lamle
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for the update! I currently test against Windows/Linux PHP 5.2, 5.3, 5.4 and XAMPP. Because there are about a million different combinations when you throw in the OS, MySQL and various web servers. I tend to rely on the community as for the most part on issues with specific setups...

    Cheers~

  9. amanumanu
    Member
    Posted 1 year ago #

    hello,
    i had the same issue on one install and i must say the 0.5 is quite nice, pretty and solved the issue.
    On an other install there's a funny bug that it makes only even packages (one time out of two) but still makes it right (with 4.6).
    tks

  10. brough
    Member
    Posted 11 months ago #

    I have the same problem. I installed on a .com using a backup created with Duplicator on my local computer, and it worked fine. Then I tried to build a backup on the remote server and got this error:

    RuntimeException thrown

    DirectoryIterator::__construct(/home/mraskew/public_html/wp-admin/F:/localhost/globaljet4.dev/wp-content/uploads) [directoryiterator.--construct]: failed to open dir: No such file or directory

    As you can see, it's added the development site address to the web address.

    How to fix I wonder. Any suggestions appreciated.

  11. Cory Lamle
    Member
    Plugin Author

    Posted 11 months ago #

    You might try the developer line which is version 0.5.3... Similar instructions are above

  12. Plotz
    Member
    Posted 3 months ago #

    This might (still) happen whenever you add personal (non-WP) folders to your WP root directory.

    As soon as you remove those folders the "Create package set" button will appear.

    Skol.

  13. Cory Lamle
    Member
    Plugin Author

    Posted 3 months ago #

    Are you still using the older 0.4.6 version? The "Create package set" button was renamed in the newer versions...

Topic Closed

This topic has been closed to new replies.

About this Plugin

  • Duplicator
  • Frequently Asked Questions
  • Support Threads
  • Reviews

About this Topic

Tags