WordPress.org

Support

Support » Plugins and Hacks » Duplicator » [Resolved] duplicator – can't download installer.

[Resolved] duplicator – can't download installer.

  • Hi,

    I love this plugin – succesfully worked on one of my sites and saved me a good amount of time. thank-you

    HOwever on a site that I need to move from one host to another I am experiencing a problem.

    The package gets created and I can save it no problem.

    The problem is with the installer. I think it’s being created, but the download link brings up an error;

    *****
    C:\Users\User\AppData\Local\Temp\K2eAVMKX.php.part could not be saved, because the source file could not be read.

    Try again later, or contact the server administrator.
    *****

    I’ve tried searching for this but can’t really get to the bottom of it.

    Is there another way of saving this file? Does it exist somewhere that I can grab it from in /wp-admin/ or something.

    Any help would be greatly appreciated.

    I’m running WP 3.1.3 by the way.

    Thanks.

    Simon

    http://wordpress.org/extend/plugins/duplicator/

Viewing 15 replies - 1 through 15 (of 23 total)
  • Plugin Author Cory Lamle

    @corylamleorg

    Hi Sjricha,

    The installer file actually always exists. Its just updated when your settings are saved.

    So the issue your actually seeing is with your download of the file. When you see a .part that means your browser either didn’t finish downloading or is in the process of downloading.

    The file is basically part of the file that is being downloaded. Once the file is completely downloaded the .part is removed and the real name of the file shows which should be install.php

    If you keep getting .part then you will need to:

    1. validate your internet connection
    2. Be sure the server your trying to download from is operational

    Hope this helps!

    Hi,

    Thanks for the update.

    Yes I can state that the connection is there. Server is fine as It’s a busy site.

    I can grab the package no problem.

    I wonder if this could be a permissions issue?

    Does the file exist at a location that I can access via ftp on my site – Pull it down that way rather than via the dashboard?

    I’ve tried to grab the installer maybe 50 times over a period of a week, if that helps.

    Perhaps if I just extract the zip’ed package and then manually make changes to the wpconfig file etc? Maybe that would work?

    Thanks again.

    Simon

    Plugin Author Cory Lamle

    @corylamleorg

    Hye sjricha,

    You will need the installer. You can find it here:
    wp-content/plugins/duplicator/files/install.php

    You can just ftp it to where ever you need it.

    Thanks

    I was having the same issue. Package downloaded fine, but couldn’t read the installer file.

    To get it via FTP you actually need to go to /wp-snapshots

    The file will be called installer.php and with a massive prefix indicating which package it belongs to.

    Plugin Author Cory Lamle

    @corylamleorg

    Thanks magician11!

    The original comments (about the installer in the plugins directory) on this thread has changed. Magician11 has provided the correct location. The installer is now located in the wp-snapshots. The leading prefix is to help secure the file.

    farazwarsi

    @farazwarsi

    Hey I checked both locations and i cant find the install.php file. When I click teh download link it says “404 page not found” – any ideas?

    Plugin Author Cory Lamle

    @corylamleorg

    The file may not be getting created. What does the log file say? Some hosts limit the ability to write files at certain locations and you will have to manually update the permissions to get the underlying PHP process to write the files out.

    I have uploaded package.zip and installer.php and when installed I loaded installer.php into browser and get a systems failed message and not the settings panel?

    Did I do something wrong?

    Plugin Author Cory Lamle

    @corylamleorg

    What kind of message are you seeing?

    I never got the settings screen just this:

    http://www.lotpropertymanagement.co.uk/installer.php

    The bulk of the site installed but none of the posts, pages or views?

    Plugin Author Cory Lamle

    @corylamleorg

    Hi henryw2007,

    Click on the “Systems Requirement Button” It will tell you what the issue is… The following items need to be fixed before it can continue:

    [Fail] Is Writable (The directory your trying to deploy to)
    [Fail] Contains only one zip file.
    Result = No package file found
    Manual extraction still requires zip file

    Checkout the FAQ it has some suggestions for fixing these issues…

    Also delete the installer file as you really what anyone on the web browsing to it…

    Hope that helps!

    My first question is this screen withhe systems requirement button was the prompt when I typed installer.php in my browser. I never had the settings where I could set up the route to the new database.

    Okay, so how do I fix the first [Fail]Is writable?
    The second [Fail] Contains only one zip file.

    I copuld not then unzip the file using my ftp. I opened it and then transferred the files over but there was no duplicate of the custopm posts or views?

    I have looked on each tutorial and the simplicity of duplicating and installing didn’t work. I have about 30 or more posts with custom fields and views and I need this all to be duplicated to be transferred over to another domain.

    Did I do something wrong?

    Kind regards.

    Nigel

    Plugin Author Cory Lamle

    @corylamleorg

    Hey henryw2007,

    First Item
    [Fail]Is writable: Check with your hosting provider to validate how the PHP process can have write access to the folder where the installer is located. There will be different rules for each hosting provider so you will need to validate with your provider.

    Second Items
    [Fail] Contains only one zip file: The directory where you put the installer.php and package.zip file you shouldn’t have any files but those two files.

    Hope that helps!

    Hi there,

    My hosting provider gave me this information but I am none the wiser:

    “It seems that you have yet to set the rights of your files and folder on your FTP. You can do this with CHMOD. You can find more instructions on how to do this here:”

    Should they do this for me?

    Plugin Author Cory Lamle

    @corylamleorg

    If your paying them, then I would have them do as much as you can have them do…

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘[Resolved] duplicator – can't download installer.’ is closed to new replies.
Skip to toolbar