Support » Plugin: Contextual Related Posts » Duplicated CRP

  • Resolved Marlimant

    (@marlimant)


    Hi, and thanks for the plugin. The best I have found.

    I habe been using this code to disable the automatic CRP location
    add_filter( 'rp4wp_append_content', '__return_false' );

    It seem after updating the plugin, that code stoped to work and now I have 2 related posts at the bottom.
    I call the plugin in my single.php using this code:
    <?php if ( function_exists( 'echo_crp' ) ) { echo_crp(); } ?>

    Any help will be appreciated.

    • This topic was modified 8 months, 2 weeks ago by Marlimant.
Viewing 6 replies - 1 through 6 (of 6 total)
  • Problem solved.
    When I updated, the plugin activated “Automatically add related posts to:” option, so I proceeded to disable it again.

    Another issue is that the plugin custom CSS rules stoped to work.
    I have copied that custom rules to my stylesheet and all it backed to normality again.

    • This reply was modified 8 months, 2 weeks ago by Marlimant.
    Plugin Author Ajay

    (@ajay)

    @marlimant,

    The former one was because of the upgrade. Thanks for checking that. I’ve tried a few iterations and I think when nothing was checked, the plugin added that option. One case I haven’t been able to solve for.

    On the second, I’m aware and will push through a fix this morning.

    Plugin Author Ajay

    (@ajay)

    v2.6.1 has been released which should fix both issues

    Thank you!
    I found out that I not need to use the code add_filter( 'rp4wp_append_content', '__return_false' ); to hide the automatic crp any more. Less is more… excellent.

    Plugin Author Ajay

    (@ajay)

    That code above looks for Related Posts for WP and not my plugin. Obviously, I do hope you’re using mine 🙂

    I’m sorry for that code.
    And I’m using yours, obviously 🙂

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Duplicated CRP’ is closed to new replies.