Support » Fixing WordPress » Duplicate title tags

  • Hello, I have a problem at Webmaster Tools, examples:

    Pages with duplicate title tags Pages
    my blog – Part 38
    /page/38/
    /page/38

    my blog – Part 76
    /page/76/
    /page/76

    my blog – Part 113
    /page/113/
    /page/113

    my blog – Part 62
    /page/62/
    /page/62

    many Dublicate title tags !! please help me …

Viewing 7 replies - 1 through 7 (of 7 total)
  • it’s hard to say without see the header.php file of your theme…

    I guess you must have some kind of function between <title>and </title> than builds the page title.

    You can access by FTP or, simply, use the “editor” in admin menu to fix the error… The easiest way is just replace the whole function by

    <?php the_title(); ?>

    this, will show only the post title…. Or

    <?php the_title(); echo ('_'); bloginfo('name'); ?>

    show post title., and blog name. You can find in internet a lot of different “title builders”… There is one i coded, has some conditional fields. it’s not perfect, but maybe can help you.

    <title>
    
       <?php
    
       if (is_archive()) {  wp_title(''); echo ' Archives '; }
    
       elseif (is_search()) { echo 'search results for "'.wp_specialchars($s).'"'; }
    
       elseif ( is_front_page() ) { bloginfo('name'); echo (' - '); bloginfo('description'); }
    
       elseif ( !(is_404()) && (is_single()) || (is_page())) { the_title(); echo (' - '); bloginfo('name'); }
    
       elseif (is_404()) { echo 'Error 404'; }
    
       if (is_home()) { bloginfo('name'); echo (' - Blog'); }
    
       if ($paged>1) { echo ' - pàgina '. $paged; }
    
       ?>
    
    </title>

    There are some conditionals to check if it’s a static page, it’s homepage (the show blog name and description) it’s a error404…

    I hope it be usefull to you

    Thanks for your interest,this my header.php

    [ Moderator Note: Please post code or markup snippets between backticks or use the code button. You forgot to close off the code. ]

    <!DOCTYPE html>
    <html <?php language_attributes(); ?>>
    <head>
    <?php global $data ?>
    <meta http-equiv="Content-Type" content="<?php bloginfo('html_type'); ?>; charset=<?php bloginfo('charset'); ?>" />
    <title><?php wp_title(' - ', true, 'right'); bloginfo('name'); ?></title>
    <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1">
    <link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>" type="text/css" media="screen" />
    <?php if(is_rtl()) { ?>
    <link rel="stylesheet" href="<?php echo Lioit_URI; ?>/rtl.css" type="text/css" media="screen" />
    <?php } else {?>
    
    <?php }?>
    <link rel="pingback" href="<?php bloginfo('pingback_url'); ?>" />
    <link rel="alternate" type="application/rss+xml" title="RSS 2.0" href="<?php bloginfo('rss2_url'); ?>" />
    <?php if(!empty($data['custom_favicon'])) { ?><link rel="icon" type="image/png" href="<?php echo $data['custom_favicon']; ?>" /><?php } ?>
    <!--[if lt IE 9]>
    <script src="http://ie7-js.googlecode.com/svn/version/2.1(beta4)/IE9.js"></script>
    <![endif]-->
    <?php echo stripslashes($data['code_header']); ?>
    <?php if ( is_singular() ) wp_enqueue_script( 'comment-reply' ); ?>
    <?php require Lioit_TM . '/css.php';?>
    <?php wp_head(); ?>
    </head>
    <body <?php body_class(); ?>>
        <?php if($data['theme_width'] == 'fixed') { ?>
        <div id="fixedContainer">
        <?php } else { ?>
        <div id="container">
        <?php }?>
    
        	<div class="topBar loadSmooth">
            	<div class="inner">
                	<nav>
    
    				<?php if ( has_nav_menu( 'mainmenu' ) ) { ?>
                    <?php  wp_nav_menu ( array( 'menu_id' => 'topNavigation','container'=> '', 'theme_location' => 'mainmenu' )); ?>
                    <?php } else { ?>
                      <ul id="topNavigation">
                         <li class="active <?php if (is_home()) {echo "current_page_item";} ?>"><a>" class="home"><?php _e('Home' , 'lioit' ) ?></a>
                         <?php wp_list_pages(array(
                        'title_li' => false
                      )); ?>
    
                    <?php } ?>
                    </nav>
                    <div class="topRss">
                        <?php if(!empty($data['social_header'])) { ?>
                        <?php require Lioit_TM . '/social.php';?>
                        <?php } ?>
                    </div><!--End topRss-->
                </div><!--End Top Bar Content-->
            </div><!--End TopBar-->
            <div id="header" class="loadSmooth">
            	<div class="inner">
                	<div id="logo">
    					<?php if($data['custom_logo'] !='') { ?>
                        <a>/" title="<?php bloginfo( 'name' ); ?>" rel="home">
                        <img src="<?php echo $data['custom_logo']; ?>" alt="<?php bloginfo( 'name' ) ?>" />
                        </a>
                        <?php } else { ?>
                        <a>/" title="<?php bloginfo( 'name' ); ?>" rel="home">
                        <img src="<?php echo Lioit_IMG; ?>/logo.png" alt="<?php bloginfo('name'); ?>" title="<?php bloginfo('name'); ?>" />
                        </a>
                        <?php } ?>
                    </div><!--End Logo-->
                    <?php if(!empty($data['show_top_banner'])) { ?>
                    <div id="banner">
                        <?php if($data['top_banner_img'] !='') { ?>
                        <a>" target="_blank" title="<?php echo $data['top_banner_alt']; ?>">
                        <img src="<?php echo $data['top_banner_img']; ?>" alt="<?php echo $data['top_banner_alt']; ?>" />
                        </a>
                        <?php } else { ?>
                        <a>"><img src="<?php echo Lioit_IMG; ?>/headbanner.png" alt="" title="" /></a>
                        <?php } ?>
                    </div><!--End Banner-->
                    <?php } ?>
                </div><!--End Main Header-->
            </div><!--End Header-->
            <div id="mainNavigation" class="navigation loadSmooth">
                <div class="inner">
                	<nav class="primary container">
    					<?php if ( has_nav_menu( 'mainnav' ) ) { ?>
                           <?php  wp_nav_menu ( array( 'menu_id' => 'dropmenu','container'=> 'ul', 'theme_location' => 'mainnav' )); ?>
                           <?php } else { ?>
                              <ul id="dropmenu">
                                 <li class="<?php if (is_home()) {echo "current_page_item";} ?> home"><a>"><?php _e('Home' , 'lioit' ) ?></a>
                                 <?php wp_list_categories('title_li=');?>
    
                            <?php } ?>
                    </nav>
                </div><!--End Inner-->
            </div><!--End Main Menu-->
            <div id="content" class="loadSmooth">
            <?php if( is_front_page()) { ?>
    		<?php if($data['disable_top_bar'] != '0') { ?>
    
            <div class="notification ondemand hide">
    
                <?php if(!empty($data['note'])) { ?>
                    <p><?php echo $data['note']; ?><a>" target="_blank"><?php echo $data['note_text']; ?></a></p>
                <?php } ?>
                <a href="">
                <img src="<?php echo get_template_directory_uri(); ?>/images/icon-close.png" />
                </a>
    
            </div>
    
            <?php } ?>
            <?php } ?>
            <?php if($data['newsticker'] != '0') {
            	 require Lioit_TM . '/ticker.php';
             } else {
             } ?>
    		<?php require Lioit_TM . '/top.search.php';?>
            <?php if (is_home()){
            if(!empty($data['show_featured'])) {
    		 require Lioit_TM . '/index-nth-slider.php';
             }
             }else {
             } ?>

    i can’t see waths wrong there :S can you post a link to the site, so i can see the problem…

    Thanks

    It’s this marked a solved ¿is solved?

    i think it’s ok ¿Whats the error? i see the title correct, just one :S

    I’m not sure if i understood the problem…

    Look, a screenshot in my computer

    Thank you Sir for your efforts ))

    the problem not solved..

    Michael

    (@alchymyth)

    Forum Moderator

    I can also not see the problem.

    however, as you are using the ‘All in One SEO Pack’ plugin, this might have to do with some settings or entries of the plugin (?) – consider to ask in the support section of the plugin: http://wordpress.org/support/plugin/all-in-one-seo-pack

    if you assume that this is caused by the code of your theme, please contact the theme’s developer for support;

    this forum does not support commercial themes; http://codex.wordpress.org/Forum_Welcome#Commercial_Products

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Duplicate title tags’ is closed to new replies.