Support » Networking WordPress » Duplicate term_id resulting in MultiSite Errors

  • I’m chasing down an issue we are having with our WordPress MultiSite installation. Currently we are on version 5.8.2.

    We have some users that have added the same tag and category to a blog. When they do this, they are unable to edit or use those tags / categories and receive an error basically stating “You need a higher level of permission.”

    In this test, I added the Tag “Test 1234” and also the Category “Test 1234”.

    The database returned the following:

    MariaDB [wordpress]> select * from wp_62_terms;
    +---------+---------------+---------------+------------+
    | term_id | name          | slug          | term_group |
    +---------+---------------+---------------+------------+
    |       1 | Uncategorized | uncategorized |          0 |
    |       2 | Blogroll      | blogroll      |          0 |
    |     456 | Test          | test          |          0 |
    |     457 | Test          | test          |          0 |
    |  107667 | Test 1234     | test-1234     |          0 |
    |  107666 | Test 1234     | test-1234     |          0 |
    +---------+---------------+---------------+------------+
    
    MariaDB [wordpress]> select * from wp_62_term_taxonomy;
    +------------------+---------+---------------+-------------+--------+-------+
    | term_taxonomy_id | term_id | taxonomy      | description | parent | count |
    +------------------+---------+---------------+-------------+--------+-------+
    |                1 |       1 | category      |             |      0 |    17 |
    |                2 |       2 | link_category |             |      0 |     0 |
    |                3 |     456 | link_category |             |      0 |     1 |
    |                4 |     457 | nav_menu      |             |      0 |    12 |
    |               10 |  107666 | category      |             |      0 |     0 |
    |                9 |  107666 | post_tag      |             |      0 |     0 |
    +------------------+---------+---------------+-------------+--------+-------+

    Reviewing what is stored in the database tables, it looks like the “terms” table is storing correctly, but the “term_taxonomy” table is recording a duplicate term_id which is causing this problem.

    Has anyone else come across this issue?

Viewing 2 replies - 1 through 2 (of 2 total)
  • Thread Starter Aaron Axelsen

    (@axelseaa)

    Update: We did upgrade to 5.9.3, and the issue persists with the same behavior. I also tested on blog 1 – and the issue is also present there.

    Thread Starter Aaron Axelsen

    (@axelseaa)

    We are not doing anything custom with categories – we are using the core wordpress functions for categories and tags and getting the behavior described above.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.