Support » Plugin: Duplicate Post » Duplicate Post not really duplicating much

  • Resolved jbrookechao

    (@jbrookechao)


    Previously, when I used duplicate post to create a copy/clone of a post in WordPress, it truly created an exact duplicate, including fields from plugins like The Events Calendar and Yoast SEO – just appending a number to the end of the URL. It would bring over all field values, including the event date, time, cost, location, organizer, SEO title, meta description, keyword, etc.

    But now, with the update to the latest version of Duplicate posts, duplicating a post or event just carries over values from the default WordPress fields. I have to select a new featured image, select a venue and organizer, and cost, and reselect a start and end time, and I have to refill out all SEO fields, even though those values really should have carried over during the duplication process. Basically, It’s carrying over the event title, url, and body content, and that’s *it*.

    I did go into the options for Duplicate Posts, and made sure everything was checked that I could (including featured image, events, locations and organizers) but it doesn’t include fields from other plugins. Why the change? Is this something that can be brought back in? Is this a bug?

Viewing 12 replies - 16 through 27 (of 27 total)
  • It now works for page builder content- thank you so much!!

    Version 3.1.2 fixes also my problem with duplicating featured images.
    Can’t do more detailed tests right now, but for the time being I’m happy…

    Thanks for the quick touching-up!

    That fixed it! Thank you so much for taking the time to reproduce the bug, and fix the issues with a new release.

    Plugin Author Lopo

    (@lopo)

    Thanks to you for reporting and being so patient while I studied the issue!

    Thanks for your quick fix!

    Hi @lopo – just a quick update – I updated the plugin to the latest version last night and now experienceing the same problem where only the default wp feilds are being cloned – everything was working perfectly before the plugin update – found this support looking for a solution and have confirm I using the lastest plugin version. – the cloning works but it does’nt appear to clone custom fields in general. WP is the current version and as above 100% worked fine on the previous plugin version the only change was the plugin update last night – any ideas would be greatful! 🙂 cheers, steve.

    Plugin Author Lopo

    (@lopo)

    Hi,
    can you try to visit “Settings”->”Duplicate Post” and just click on “Save”, to make sure there isn’t any inconsistency, then try again?

    Hi @lopo – thanks for your reply, quick note have tried above including uninstalling / re-installing still not working as expected – also a developer here so i don’t mind looking into it a bit further myself and see if there are any issues / server errors or something not playing right at my end that I don’t know about. – in the meantime I’ll revert back to the old version for now – keep you posted – cheers,

    Howdy. I like this plugin but it is not duplicating 1 specific element.

    I use Woocommerce Memberships plugin but Duplicate Post does not reference this element anywhere 🙁

    If you an get this working I’ll gladly donate $100 🙂

    Site is http://www.carrielachance.com

    Plugin Author Lopo

    (@lopo)

    Hi @archenemys,
    can you write me here explaining what’s the problem? This is a thread regarding another issue that has been solved.

    I responded to you a few days ago…

    I would like to chime in on this. Using the latest version of WordPress (4.8) and the plugin as of June 23 2017.

    This plugin does not seem to copy over any meta data. We have both public and private meta fields (_private_meta_key_name); So things like Yoast and The Events Calendar data is not coming over. Only title and content. I’ve hit the save button again on settings.

    Meta fields are also supposed to be duplicated, right? I was looking for a setting checkbox for “meta” but didn’t see anything.

Viewing 12 replies - 16 through 27 (of 27 total)
  • The topic ‘Duplicate Post not really duplicating much’ is closed to new replies.