Support » Plugin: Duplicate Post » Duplicate post add -2 also to original post

  • Resolved rpad2706

    (@rpad2706)


    The latest version of duplicate post seems to have an bug. It add -2 to the new concept item AND it also add -2 to the original item, where as a result the original post/page doesn’t work anymore. I’ve tested this with 2 different websites where it occured. I’ve already de- and re-installed duplicate post, unfortunately this hasn’t solved the problem

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Author Lopo

    (@lopo)

    Hi @rpad2706,
    it’s very strange because Duplicate Post doesn’t do anything at all to the original post, let alone changing the slug. A few people has reported a similar issue but they didn’t add any useful information and I suppose there is some incompatibility with a theme ore plugin.

    Did it happen with version 3.2.2? Can you test it?
    What the two website have in common? Same theme? Can you list their plugins?

    Thanks for your help!

    rpad2706

    (@rpad2706)

    Hi @lopo , well it seems that duplicate post does something with the original post. I’ve never experienced it before and i use the plugin for years now. The 2 website are completely different with different themes and plugins have nothing to do with each-other (different company’s, hosting etc.). My website use the following plugins (I can’t post plugins from the other website who is affected also because it’s not from me):

    add-url-slugs-as-body-classes/
    all-in-one-wp-security-and-firewall/
    disable-feeds/
    disable-json-api/
    duplicate-post/
    enhanced-media-library-pro/
    LayerSlider/
    mainwp-child/
    most-popular-tags/
    obfuscate-email/
    page-shortcode/
    rename-media-files/
    replace-image/
    search-and-replace/
    subs-shortcode/
    tinymce-advanced/
    tr-post-slider-widget/
    widget-title-links/
    wordpress-seo-premium/
    wp-database-backup/
    wp-glossary/
    wp-rss-aggregator/

    Both websites use WordPress 5.2.2

    • This reply was modified 3 months ago by  rpad2706.
    rpad2706

    (@rpad2706)

    I’ve just tested it with 3.2.2 , still not good. I’ve noticed that in 3.2.2 it uses the word Clone instead of ‘kopieer’ (from which version is ‘Clone’ introduced?). I’ve never noticed that so I presume a older version then 3.2.2 must be still free from this bug.

    rpad2706

    (@rpad2706)

    Hi @lopo , I’ve just tested it with version 3.2 and that works well!!! Hopefully now you can analyse where it goes wrong!

    Plugin Author Lopo

    (@lopo)

    Hi @rpad2706,
    “Clone” was added in Duplicate Post since version 2.0 eight years ago…

    Were they new installs or did you update from a very old version?

    Can you check the settings of the plugin to see if the “Slug” option is enabled, and if so, disable it and try again?

    rpad2706

    (@rpad2706)

    Updated again to 3.2.3. Disabled “slug”. It works fine now!!
    And is says ‘Kopieer’ again instead of clone :-). Thanks for the solution, keep up the good work!

    I’m experiencing the same issue when “slug” is activated. Sometimes it’s working like expected but sometimes the duplicated post keeps the original slug and the original post gets “-2”. The bad thing is that you only notice when you check the slug of the original post. In the worst case, you only notice when it has been updated on the search engines already.

    Plugin Author Lopo

    (@lopo)

    Hi @doncamillo1,
    as suggested above you should leave the “Slug” option unchecked (it’s the default) in 99% of the cases: the slug will be recalculated from the title, or you will be able to change it before publishing the copy.

    maverickdev

    (@maverickdev)

    We are intermittently experiencing the same issue. The “Slug” option is unchecked but sometimes when we clone an existing post, the original post gets a “-2” added to the permalink.

Viewing 9 replies - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.