Support » Plugin: Customize WordPress Emails and Alerts - Better Notifications for WP » Duplicate “New Post Published” emails

  • Resolved newslicer

    (@newslicer)


    Hello Support,

    I’ve seen that some people are having or had problems with duplicate mails. In my case it’s duplicate “New Post Published” emails going out to my subscribers.

    Some stated that a plugin my cause those problems and I might have that problem too.

    Buy my question is: what would be the best approach to narrow down this issues? I have a lot plugins running and would not like to “trail and error” this effect. Is there some logging that might help? Anything to prove this behavior?

    Plese let me know.

    Kind regards

    Andre

Viewing 10 replies - 1 through 10 (of 10 total)
  • FragMagnet

    (@fragmagnet)

    I’ve noticed this issue recently as well. I did some troubleshooting by disabling everything other than BNWP and my SMTP plugins, but it persisted. The official site suggests using the classic editor plugin, and it seems as though this fixes the issue.

    Unfortunately, this isn’t ideal for me since the classic editor, in turn, breaks a few plugins I use with the block editor. However, it does imply that the most recent update to the block editor is at least partly responsible for this issue.

    I initially found that saving and viewing a preview before publishing the post helped circumvent the bug, but today I had it happen again in spite of this.

    Hopefully this can be handled soon.

    Thread Starter newslicer

    (@newslicer)

    Thanks for your message FragMagnet. I have a lot of plugins (good ones I hope) running and would not like to disable them step by step. Using the classic editor would also not be an option for me. Yesterday I installed WordPress 5.5 and maybe the problem goes away with that. I’ll have to test it. But on the other hand: maybe it’s possible to trace or log BNFW itself to see where the cause of the problem is. It only occurs (on my blog) with “new posts”. Sending mails for new comments are running fine.

    Plugin Author bnfw

    (@voltronik)

    Hi @newslicer and @fragmagnet,
    Thanks for helping each other narrow down the issue – I’ve been away for a few days so am catching up.

    It’s possible that the latest version of the block editor is causing an issue. I’ll add it to my todo list as something I need to re-test.

    Are you both using the Gutenberg plugin or just the block editor that’s built in since WP 5.0?

    Thread Starter newslicer

    (@newslicer)

    Thanks for catching up @voltronik 🙂

    I’m using the build in block editor since WP 5.0.

    Plugin Author bnfw

    (@voltronik)

    Thanks @newslicer,
    I’ll see what I can find out.

    Thread Starter newslicer

    (@newslicer)

    I just wanted to say, that the problem still occurs. Unfortunately. I would really like to fix this.

    While this shouldn’t constitute a fix, I did manage to find a simple workaround since this problem surfaced.

    After finishing your post, save it as a draft, then go to your post listings.

    Click on “Quick Edit” for the post, then change its Status to “Published.”

    This has consistently avoided the double notifications for me since I’ve been using it, as the erratic behaviour still seems linked to a strange interaction between BNFW and the block editor.

    Hope it helps.

    Thread Starter newslicer

    (@newslicer)

    Dear @fragmagnet, thanks for that hint! I’ll try this the next time. That sounds very helpful.

    @voltronik: did you find anything on this issue by now?

    Kind regards to you both

    Andre

    Plugin Author bnfw

    (@voltronik)

    Hi @newslicer and @fragmagnet,
    Have you tested with the default Twenty Twenty theme? My thinking is f the issue seems to be only when using BNFW and the Block Editor, I’m wondering if a theme is creating an incompatibility too. Just trying to rule everything out.

    Plugin Author bnfw

    (@voltronik)

    Closing due to inactivity. If you need further help with this, please feel free to re-open this thread.

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.