Support » Plugin: Max Mega Menu » Duplicate menu / can’t toggle closed

  • Resolved Beth

    (@pedalkraft)


    Hi,
    My mobile site shows two menu toggle bars – the first is dead, the second toggles the menu.
    I’ve searched for this problem and found this:
    https://wordpress.org/support/topic/duplicate-menu-on-mobile-device/
    – thing is, when I check this box, the mobile menu displays permanently open, whereas I want just one menu toggle bar, to default to closed.
    Can you tell me how?
    Thanks

    • This topic was modified 7 months, 4 weeks ago by  Beth.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author megamenu

    (@megamenu)

    Hi Pedalkraft,

    Please go to Appearance > Customize > Additional CSS and add the following:

    .mega-menu-primary .menu-toggle {
        display: none !important;
    }

    (if the change does not show up, remember to clear your autoptimize cache)

    Beth

    (@pedalkraft)

    Thank you! That’s solved it 🙂

    Hi there … not sure if I am in the right forum or not, but here’s my question:

    Website: http://healingconversationswithmildredlynn.com/

    My Primary menu has eleven items: Home, Podcast Directory, Blog, What People Are Saying, About Me (and on the lower half), Healing Conversations, Two Owls Having a Hoot, Walk the Talk to Health, Let’s Talk About, Meet the Team.

    When I click on any of the above Primary Menu items, the display is normal (in that the other items show up in the Menu bar). When I click on “Blog”, the About Me menu item shows up in the display four times. I have tried to figure it out (Google, etc.), but I am perplexed.

    If someone would be kind enough to offer a suggestion, it would be greatly appreciated.

    Thank you for your help … and feeling optimistic 🙂 ML

    Just revisited the website and oddly enough the Primary Menu > Customizing Menus Visual Display looks normal when I click the “Blog” menu item. The Primary Menu navigation (left-hand side) looks normal; the visual display (to the right) looks normal; I pressed the Publish button. It says “Published”.

    I cleared Google Chrome history, browsing data, and cashe. When I go back to the website and click on “Blog” I still get the four “About Me” menu items. (http://healingconversationswithmildredlynn.com/blog/)

    Thank you again for your help 🙂

    ML

    Plugin Author megamenu

    (@megamenu)

    Hi ML,

    These forums are specifically for people using the “Max Mega Menu” plugin. I’ve checked and I don’t think you’re using it, so your question would be more suited to be posted here:

    https://wordpress.org/support/forum/how-to-and-troubleshooting/

    (scroll to the bottom of that page to create a new topic)

    If it helps at all, I have checked the menus on your site and they both behave as I would expect them to!

    Hi megamenu,

    Thank you for getting back to me so quickly and pointing me in the right direction with the appropriate WordPress support link – much appreciated. I will happily head there in a few minutes.

    Also, thank you for taking the time to check the menus on my site (good to hear that they are working A-OK). It was very nice of you to take that extra step.

    My first Word Press Support forum experience has been great :)))

    Enjoy the day!

    ML

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.