Support » Plugin: Easy Footnotes » Duplicate Footnotes When Using Elementor

  • When using the plugin with the page builder Elementor, every footnote is duplicated. For example, on one page we have 40 footnotes and the plugin has created 80.

    The number of the footnotes in the viewable text starts at 41. And the first 40 link back to a URL that doesn’t exist (e.g. https://www.domain.com/#easy-footnote-1-1111 doesn’t actually exist but is a duplicate of https://www.domain.com/#easy-footnote-41-1111 which is actually the first footnote in the text).

    We took the same text and used the built-in editor (not page builder) and it worked fine. So there’s definitely something going on with the plugin and elementor.

Viewing 1 replies (of 1 total)
  • Plugin Author Jason Yingling

    (@yingling017)

    This typically happens when the_content is called multiple times on a page. Easy Footnotes works by hooking into the_content filter and reading all of the footnotes then adding them to the bottom of the post. Sounds like something is running the_content filter and causing the footnotes functionality to run doubling the count.

    May be something that uses the apply_filters('the_content', $content) function in the theme or plugin causing it. Basically when the_content filter runs the easy footnotes functionality runs. And that filter can be run directly with apply_filters('the_content', $content) or with the_content().

Viewing 1 replies (of 1 total)
  • The topic ‘Duplicate Footnotes When Using Elementor’ is closed to new replies.