Support » Plugin: WordPress Gallery Plugin - NextGEN Gallery » Duplicate Content errors

  • Resolved nortok00

    (@nortok00)


    Hello,

    WP: 4.6.1
    NextGen: 2.1.57

    Apologies if this has been asked and resolved. I did a search and couldn’t find anything that addressed my issue. If this has been asked/answered just point me to the solution.

    I have a situation with a site using the NextGen plugin. The site has a bunch of standard pages setup with content descriptions and the NextGen gallery shortcode inserted for various galleries they have created. The page displays a content block and then static images from the gallery via a shortcode. When running a check on the site I noticed a bunch of SEO duplicate content errors. I discovered a bunch of sub-pages that were created (I’m assuming by the NextGen plugin) that have the exact same content as the upstream page but instead of static images it presents a slideshow version. All of these URLs end with /nggallery/slideshow

    Example URL structure:
    http://www.mysite.com/gallery-page1 (this has a content block followed by a gallery showing static images) then there is
    http://www.mysite.com/dallery-page1/nggallery/slideshow (this has the exact same content as the upstream page except instead of static images it displays a slideshow of the gallery)

    This is repeated for every page that has a gallery on it. This means I’m getting duplicate H1 errors, content errors as well as H2s, etc. Everything is duplicated.

    I have been through the settings but can’t find a way to control this so I thought I would ask this forum in case I missed something.

    Questions:
    1. Is there a way to disable slideshow view in the plugin? (the site isn’t using this view)
    2. Is there a way to set the galleries (or at least the slideshow view) to noindex/nofollow?

    All searches I came across for this issue say the only way to stop this is to do a disallow on the problem directories in robots.txt. I’m hoping an issue like this would have solutions to control it via the settings instead of resorting to robots.txt.

    If the only solution at this point in time is robots.txt can I ask for a feature update to have the ability to turn off certain views (like slideshow view) as well as be able to set noindex/nofollow on galleries just like we can with pages and posts. In my scenario it’s these /nggallery/slideshow views that are the issue and it’s these I want to control.

    Thanks.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author photocrati

    (@photocrati)

    @nortok00 – NextGEN Gallery Basic Thumbnails display types generate a default link to a slideshow version of the gallery. This view is displayed on a dynamically generated page although the link itself appears to exist to an actual page.

    For each inserted display you can change its options to not display the slideshow link, then under Gallery > Gallery Settings > NextGEN Basic Thumbnails you can further set the option again so it is not used for new inserted thumbnail displays.

    Thanks!

    – Cais.

    Thread Starter nortok00

    (@nortok00)

    Thanks so much for the speedy reply!! I didn’t see any of these options when going through the settings and various galleries so appreciate the exact method to control this. Having said that I might have seen them but didn’t correlate it to stopping these duplicate content issues so probably scrolled right by them. I appreciate you explaining how this functions which makes more sense regarding the settings you mentioned.

    If I have issues I will follow-up via this post or will reply saying all is fine.

    Thanks again!!

    Thread Starter nortok00

    (@nortok00)

    Hi back Cais,

    OK, I just went into the NextGen plugin and I don’t understand what you mean by “For each inserted display you can change its options to not display the slideshow link”. Where do I do this? Is this under “Manage Galleries” or is this done in the shortcode of each page a gallery has been inserted? I don’t see this option in either location and there is no slideshow link on any of the pages that have the gallery shortcode. The only thing on the page is some content and the static images for the gallery. As a matter of fact I didn’t even know these pages existed (because there is no link to the slideshow version) until I did a crawl of the site to get all of the URLs appearing.

    Please advise. This is affecting a lot of pages.

    IMHO… if this plugin is to be SEO friendly then I think there should be the option for each gallery to select whether you want to display a static view or a slideshow view that way you’re not disabling the option for slideshows (as it seems to be with the directions you gave me) and you don’t get duplicate content issues. It should be selectable as one or the other for each gallery (static or slideshow) and not the current method of it automatically creating the slideshow page. Having it selectable allows the owner to decide which view to use and on which page. (Just my two cents).

    Thread Starter nortok00

    (@nortok00)

    Update: I found the reason why the slideshow link isn’t showing on each page that a gallery has been inserted. It has been set to “display:none” in the css. I can only assume it was because the person managing the site didn’t know there was an option to disable this so did this.

    Having said that I can’t find this option either. Please explain exactly where to find this. As per my previous reply… I don’t understand your response “For each inserted display you can change its options to not display the slideshow link”. Where is this and does the option you mention do “display:none”? If so this is still crawlable and indexable by the search engines (display none only hides it from view… not the search engines) so this will not resolve my issue of duplicate content if this is what the option does. In fact… you get dinged by the search engines for doing stuff like this.

    Please advise… I have to find a resolution to this or possibly find another plugin. I hope you will consider my suggestion in my previous reply on how to resolve this problem.

    Thanks.

    Thread Starter nortok00

    (@nortok00)

    Update 2: OK. I found the option. I never use Visual view when I’m looking at pages (only Text). That’s why I couldn’t find it.

    It turns out some previous developers set the link to “display:none” probably because they couldn’t find this option either.

    Is there a master setting to to turn this off? The site in question has about a hundred galleries. This will take forever. If there is no master setting I hope you will consider my suggestions from my first reply (to make this more SEO friendly) which means a master setting for this won’t be needed OR add a master setting to disable this if you don’t plan to implement my suggestions.

    Thanks.

    Thanks.

    Plugin Author photocrati

    (@photocrati)

    @nortok00 – The only way to change this for all inserted displays currently is to remove the relevant shortcode parameters as needed; or, in most cases, use the visual tab of the TinyMCE editor and then re-open each inserted gallery, open it’s customization accordion panel and uncheck the option to show the slideshow link.

    For future displays being inserted you can have this as the default under Gallery > Gallery Settings > NextGEN Basic Thumbnails.

    The design and ideas behind the Insert Gallery Window (IGW) was to maintain the settings for each inserted display to insure that you can manipulate and display any gallery in any number of ways. We do not have intentions to change this approach although the new generated shortcode approach we are using does work more like a “global” effect that the previous <img> tag placeholder approach.

    If you are using old NextGEN Legacy shortcodes (they look something like [nggallery id=1] then you may be able to just change the show slideshow link in the Gallery Settings. You may also need to clear the image cache under Gallery > Other Options > Miscellaneous to see the effects of these changes immediately (not to mention any other caching plugins/services/mechanisms you may be using as well).

    Thanks!

    – Cais.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Duplicate Content errors’ is closed to new replies.