WordPress.org

Forums

dumb me! Changed URL in General Settings (11 posts)

  1. Shea la Vie
    Member
    Posted 2 years ago #

    Hey all, my site is http://www.hopesoapworks.com but it's not working now because I stupidly changed the wordpress address URL in my general settings. (I did not changed the site address, just the WP)

    Found this help article in the forums and have been trying to hardcode (as described in option 1) the corrections in through my host (bluehost) from within the wp-admin.php file for that site.

    I just can't figure out where to put the code...duh! I've tried it several places that don't work, so remove it and re-save...then try another spot. I am not code savvy at all, so any guidance appreciated!

  2. krembo99
    Member
    Posted 2 years ago #

    The best and easiest way is to go to PhpMyadmin , and change the options there .

    1 : go to your DB -> DB_PREFIX_options (options table)
    2 : Locate option name "siteurl" - change to your new value
    3 : click edit - change to your new value - click GO.
    4 : Locate option name "home" and repeat step 3 with SAME value
    5. Go to website and login ... all is done

  3. Shea la Vie
    Member
    Posted 2 years ago #

    Thanks for jumping in to help!

    OK, I found all of that, but it's not working unless I've done something wrong again....

    when I mistakely changed my general settings inside from the dashboard , I did this:

    wordpress URL changed from hopesoapworks.com to wildbelles.com
    I did not change the site URL so it is still set to hopesoapworks.com

    From your directions above and from within PhpMyadmin, I changed the site url to hopesoapworks.com and clicked go

    then I found the home option and it was still set to hopesoapworks so I left it the same

    My website still isn't showing so I know something is still wonky:/

  4. Marvie Pons
    TutsKid Ninja
    Posted 2 years ago #

    This might help > Changing The Site URL

    edit: never mind this... didn't see your link

  5. Marvie Pons
    TutsKid Ninja
    Posted 2 years ago #

    I just can't figure out where to put the code

    Put it in wp-config.php file, in your WordPress root directory

    Just before the --> /* That's all, stop editing! Happy blogging. */

  6. Shea la Vie
    Member
    Posted 2 years ago #

    Thanks anyway marcipons...I'll take all the help I can get:)

    ahhh geez...marviepons...tired here.

  7. Shea la Vie
    Member
    Posted 2 years ago #

    I will try that!

  8. krembo99
    Member
    Posted 2 years ago #

    ok, somone just spammed this thread , but anyhow, it seems to me that you did not simply changed the site URL, but what you are after is a domain change ... am I correct ?

  9. Shea la Vie
    Member
    Posted 2 years ago #

    Well, a domain change is my final goal, but I was so close to completing the site, I was just going to finish it and then deal with changing the wp and site urls at a later date. I wrongly assumed that I could just go back into general settings and change things back. But of course, now I can't log into the site at all.

  10. krembo99
    Member
    Posted 2 years ago #

    did you put the full site url in the options table via phpmyadmin ?? e.g.
    http://www.hopesoapworks.com

  11. Shea la Vie
    Member
    Posted 2 years ago #

    I don't think so, but I did get my site back up and am able to log in now! I had changed so many things I think I lost track and didn't change some errors back. Perhaps that was one of them. I found an error log in my bluehost files that showed me just where it was, removed it and now all is good. I can't thank you enough for following up and trying to help me!

Topic Closed

This topic has been closed to new replies.

About this Topic