Support » Alpha/Beta/RC » Dude, where’s my Draft?

  • Resolved Chris_K


    I’m not sure if this problem came from the upgrade to RC3 or upgrading mysql.

    As near as I can tell, everything about my blog is functional except the ability to Save or “Save and continue Editing” a post. When I use either of those, I lose the post. forever. like, not to be found in the database.

    I just lost 3 posts before I realized I had an issue. In some additional experimentation, I can tell you I see no errors or indication that anything bad has happened.

    Thoughts or suggestions?

Viewing 8 replies - 1 through 8 (of 8 total)
  • This is very off indeed, so I suggest we explore what leads to this behaviour. What happens if you publish directly? What are your server’s settings? Browser should play no role, I suspect. Is it possible that your account is low on space or perhaps the database cannot be accommodated properly? Any similar issues with previous versions — or rather I should say — did you run WordPress successfully before? On the same server?

    To answer your questions:

    * Publishing directly is fine. It works.
    * I own the server. I have approx 20GB of space available to me. 🙂
    * Has been working fine (as wp 1.5 and mysql 4.1.x) for several months.
    – I upgraded mysql a few days after I upgraded wp to beta2 rc3. I regret that I didn’t think to try the “draft” functionality before the mysql upgrade.

    Drafts do not work with WP2.0 and MySQL 5 strict-mode. I don’t know if they work with MySQL in loose mode.

    ah, that’s interesting. Thank you for sharing that!

    I suppose I should see what it takes to take mysql out of strict mode. I’m rather clueless about that product.

    Finally got a chance to wrap this one up. Added an issue to trac and then commented out the “strict” line in mysql’s my.ini file. That seems to have fixed me up for now.

    So yes, drafts do work in “loose” mode with mysql 5.x.

    Thanks for all the responses.

    MySQL 5 *should* be run in strict mode. WP does not comply to the SQL2003 standards, so the solution is not to disable strict mode (standards mode), but to fix WP’s INSERT commands to get rid of the errors they cause.

    I’d tend to agree, philosophically, with you RustIndy.

    And I also wanted the ability to do drafts *now*. Thus, a trac issue *and* a work-around (temporarily, one hopes).

    I’m having the same problem on Windows with MySQL 5.

    But I did discover this… if you publish the article then
    go back to edit it and set it to draft, it works in strict mode.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Dude, where’s my Draft?’ is closed to new replies.