Support » Plugin: Yoast SEO » Dubbele pagina, ingediende URL niet geselecteerd als canoniek

  • Resolved v.307

    (@victor307)


    Hello Yoast team,

    Google Search Console gave this message:
    Dubbele pagina, ingediende URL niet geselecteerd als canoniek
    (I think it means I have two pages that are more or less the same).

    I am trying to fix this (remove the page: homepage/welkom), going to Pages > Homepage, then I try to remove the slug “Welkom” in the Yoast SEO settings on the page, but I can’t remove it.

    Could you please tell me how I can fix this issue? Thanks in advance.

    • This topic was modified 4 months, 1 week ago by v.307.
    • This topic was modified 4 months, 1 week ago by v.307.

    The page I need help with: [log in to see the link]

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support Michael Tina

    (@mikes41720)

    Hi @victor307

    Just to clarify, for this page https://www.magieshop.nl/welkom/, you’ve set it as your static homepage under WP admin dashboard > Settings > Reading, right?

    If so, we would expect that the /welkom/ part of the slug would be stripped as it would then be generated as the homepage (without any slug) as it was designed as the homepage.

    Or is this another separate page and you’ve set the canonical URL to just https://www.magieshop.nl/ in the settings?

    Thread Starter v.307

    (@victor307)

    Hi Michael, thanks for your response.

    Please see this uploaded screenshot with WP admin dashboard > Settings > Reading:
    https://ibb.co/8jYTrvn

    The page “magieshop.nl/welkom” does not show up below WP admin dashboard > All pages. (I don’t need this page to exist, because I already have the homepage)

    The only place I can find the slug “welkom”, is when I click to edit the Homepage(which is also the shop-page), en than scroll down to:
    https://ibb.co/fHB3bnM
    This is where I can not remove the slug. When I remove it, it automatically replaces the slug with “magieshop-nl”.

    I would like the remove slug for the homepage, I think that would solve the Google Search console issue?

    Plugin Support Michael Tina

    (@mikes41720)

    Hi @victor307

    When checking https://www.magieshop.nl/welkom/ again, it seems to load a status of 500, which is a server error. You’ve mentioned that the /welkom/ page doesn’t show up in the pages overview.

    We suspect this might be an issue with your theme or how it generates the pages, as the standard WordPress behavior should be that any page that you set as your homepage (in the Settings > Reading section), it would keep the slug in the backend, but it would display without any slug when loading on the front end.

    Thread Starter v.307

    (@victor307)

    Hi @mikes41720

    Thanks for your response. I do not know why you see a status 500 (server error).

    I think why the conanical-page is being made, is because in the Woocommerce-Products-Settings, I have selected my “Woocommerce shop page”, to be (shown on) the “Homepage”.

    So maybe most of the webshop-websites have their shop-page and home-page seperated. But in my case these are the same. I think that is why the /welkom page does show up in the “product-sitemap.xml” generated by the Yoast plugin.

    If I am correct, probably the Yoast plugin could improve even further, by filtering this “double, or as google calls it canonical page”, so it does not show up in the “product-sitemap.xml”.

    Or maybe Yoast advices from the SEO best practices point of view, to keep the shop-page and the home-page seperated? Maybe, in that case the Yoast plugin could give a notification when a user selects the shopping-page, to be the home-page?

    Of course I am by fare not as knowleged and technical as you are, but I try to think what would be a good solution. Looking forward to your response. Thanks again.

    Plugin Support Michael Tina

    (@mikes41720)

    Hi @victor307

    We’re checking on the page again (/welkom/) and it doesn’t load with a status 500 anymore, now it loads as expected with a status 200.

    It does seem to be the case when you’ve also set your WooCommerce Shop Page as the homepage/frontpage, that the slug would still appear, as per this WooCommerce forum thread.

    We recommend you reach out to WooCommerce for further advice regarding the slug output as well.

    From an SEO perspective, we can’t advise what the best practice would be, but having the canonical URL point to the version without any permalink or slug does seem to make sense since they’re technically the same page.

    Thread Starter v.307

    (@victor307)

    Hi @mikes41720,

    Thank you for the support. I have pointed the /welkom page to the homepage. Maybe in the future I will just seperate the homepage and the shopping page, and then remove the redirection. Appreciate your help.

    Best regards,

    Victor307

Viewing 6 replies - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.