Support » Plugin: Elementor Page Builder » Dual / Overlapping Lightboxes

  • Resolved saucer78

    (@saucer78)



    I’m running an older theme that seems to have developed a conflict with Elementor, or actually, the other way around.

    I have tried everything within my ability to tweak the lightbox settings amongst the two, but cannot keep both additions to WordPress from throwing up their own version. For every image I have the lightbox enabled, I get a theme lightbox AND a plugin lightbox, right on top of one another, that requires to clicks to close out completely.

    Any idea how to disable one of these, but allow the other to work? I really have no preference, so long as I don’t have to layout another theme…

    Thanks!

    (All plugins are updated, WP is updated, and I have toggled additions to identify the culprit being an incompatibility with the “Hatch” Theme I have been using for the past few years.)

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Support Ben Pines

    (@benpines)

    You can switch of Elementor’s lightbox. Check this out: https://docs.elementor.com/article/217-lightbox

    saucer78

    (@saucer78)

    Thank you Ben, but I’ve tried this within the Elementor style settings from the WP dashboard, and from within the Elementor settings for the individual elements on each page. If I toggle the lightbox on individual elements, I will see the old lightbox from the Hatch theme disappear, but once I save the settings and look at a live view of my site, it’s back.

    If I turn the Eleemntor lightbox completely off, it will also kill the Hatch lightbox and killing the link. In short, it’s all or nothing: overlapping lightboxes or none at all.

    • This reply was modified 8 months ago by  saucer78.
    0be1

    (@0be1)

    Saucer78;

    Are you using a cache plugin as well. If so, try Ben’s suggestion again, but before you do, do two things. 1) clear any caching plugins, and maybe even disable for testing purposes.

    2) Clear your browsers cache and then also do a hard browser refresh. ctrl+f5 for Windows, cmd+shift+R for Mac. Also remember, not all themes are currently supported by Elementor.

    saucer78

    (@saucer78)

    Thank you Obe1, I’ll look into this.

    It’s a shame if Elemetor has broken compatibility with this theme through updates, as they were working perfectly well together for nearly three years.

    saucer78

    (@saucer78)

    Nothing is sticking.

    I’ve once again checked my plugins to find nothing keeping a cache, and cleared browser data/refreshed the page many many times.

    When I play with the toggles within the Elementor editor (switching to and from ligthbox: yes, no, default) and within its global settings, I can trigger the correct display where it shows ONLY the the Elementor lightbox. However, no matter what I do, I cannot get this to save. Every time I view the site from a new browser window (logging out of WP/incognito mode/clearing cache/other browsers/ctrl+F5) it will still show both lightboxes.

    Something within Elementor has begun triggering Hatch’s lightbox, but I don’t have the know-how to comb css/html to figure out what it is :/

    EDIT: Actually, I don’t believe Elementor has begun triggering the Hatch lightbox because the Hatch style is what I remember the site having when I originally built it. It actually appears to me that Elementor has ADDED a lightbox feature within a relatively recent update, which has somehow become intertwined with the Hatch code. Unfortunately, when I disable the Elementor lightbox it ALSO disables the old Hatch lightbox, simply leaving me with nothing.

    • This reply was modified 8 months ago by  saucer78.
    • This reply was modified 8 months ago by  saucer78.
    • This reply was modified 8 months ago by  saucer78.
    saucer78

    (@saucer78)

    Figured it out!

    Allowing the Hatch lightbox to take over requires disabling the Elementor lightbox from the main WP settings panel and then setting each image to “default” from the dropdown within the Elementor editor within each page. I don’t know how I didn’t land on this combo sooner, but I’m just happy to have found a solution.

    Thanks for the help!

    • This reply was modified 8 months ago by  saucer78.
Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Dual / Overlapping Lightboxes’ is closed to new replies.