Support » Theme: Rosa Lite » Dropdown menu on Edge doesn’t work

  • Resolved iguanamom

    (@iguanamom)


    hi,

    I made some menu heading links (using #, so basically it doesn’t go anywhere) with pages beneath them. Using Edge, you can’t click on those and see the dropdown menu at all. It does nothing. HUGE PROBLEM. How can this be fixed?

    Thanks.

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • It doesn’t work on your demo either when you try to click on ‘Features’: https://demos.pixelgrade.com/rosa-lite/

    I installed mega menu to fix this, but I don’t want to keep it. You can find an example of it not working on your demo. I’d like to see a fix for it still. Apparently it’s an Edge issue not paying attention to :focus-within. I staged the site, went through style.css and looked for .sub-menu-parent:focus-within .sub-menu but it wasn’t there. Then I removed all instances of :focus-within and that didn’t work either.

    Also tried adding this between head tags in header.php didn’t work (with and without the focus-within) <meta http-equiv=”X-UA-Compatible” content=”IE=9″/>

    I disabled pixcode and pixtypes, didn’t change. Removed all custom css, didn’t change.

    Thought I’d try the Rosa 2 theme but checked your demo first and the dropdown doesn’t work on there either using either Features or English dropdowns: https://demos.pixelgrade.com/rosa2/

    Someone else had a problem and I attempted to modify this with the classes I saw, but it didn’t work (it was probably me):

    .main-navigation ul li:hover > ul,
    .main-navigation ul li:focus > ul {
    left: 0;
    }
    .main-navigation ul ul li:hover > ul,
    .main-navigation ul ul li:focus > ul {
    left: 100%;
    }

    So it seems that it could be easily fixed with some simple CSS, I’m just not very good at it.

    Thanks!

    iguanamom

    (@iguanamom)

    Hi,

    any response to this issue with Edge?

    Thanks

    Turns out Edge hadn’t updated itself so when I forced an update, it worked.

    Theme Author pixelgrade

    (@pixelgrade)

    Hey,

    I tried to replicate the issue and it looks like you were right, the sub-menus are not being shown on older versions of Microsoft Edge.

    I will open an issue on GitHub and the issue will be solved in the next update.

    Thank you for reporting this issue.

    Stay safe,
    Madalin
    Pixelgrade

    • This reply was modified 2 months, 3 weeks ago by pixelgrade.
Viewing 5 replies - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.