Support » Theme: Kadence » Dropdown menu disappearing on mouse hover

  • Resolved molde12

    (@molde12)


    After updating to version 1.1.2 the drop down menus of the main header menu disappears when I hover over them with the mouse pointer. When the menu disappears the links in the drop down cant be reached. I cleared the browser cache and tried it in the backend. This is were the problem occurs. I have not yet cleared my WP front end cache so it is still working. I am using Windows and Chrome.

    The page I need help with: [log in to see the link]

Viewing 12 replies - 1 through 12 (of 12 total)
  • Thread Starter molde12

    (@molde12)

    I also noted that the mobile menu is affected by the update. Some of the lines between the links are missing. I use iPhone 12 max.

    Dropdawn menu is broken!

    Rollback to version Versión 1.0.30

    Hi,
    I’m not seeing this on our test sites or demo sites. I can’t seem to recreate it. Perhaps there is a css specificity issue with a caching plugin?

    I’ll push out an update in a few minutes with some added css specificity.

    Ben

    Thread Starter molde12

    (@molde12)

    Thank you, I will report back after the update. I also made a ticket on your website free support where I uploaded two pictures of the mobile menu. Everything has been working fine and after the update I had two problems. I am viewing the backend in incognito mode, and it is not cached. When I hover over the main link the dropdown is showing but when I move the cursor down to choose a link the drop-down disappears.

    Thread Starter molde12

    (@molde12)

    I have checked further and there is a larger gap now between the main menu link and the drop-down. When I drag the cursor slowly over the gap the drop down is closing like I reported. If I move the cursor really fast over the increased gap the dropdown stays open and works. I hope that make sense.

    I pushed out an update let me know if that resolved this for you.

    Ben

    Thread Starter molde12

    (@molde12)

    You resolved it! Everything is working perfectly now. Thank you.

    Don´t work for me. My populated menu items lost all classes . In version 1.0.30 the classes of li menu items are there, i use JC menu to populate menus. in this version works, i lastets no.

    i resolve adding this function but i don´t know is the best option because a need to add type obect classes, like… term or post type dynamically

    function wpdocs_menu_item_title_css_class( $classes, $item ) {
      $classes[] = 'menu-item menu-item-object ' . sanitize_html_class( sanitize_title( $item->title ) );
      return $classes;
    }
    add_filter( 'nav_menu_css_class', 'wpdocs_menu_item_title_css_class', 10, 2 );
    • This reply was modified 1 month, 3 weeks ago by sermalefico.

    Hey,

    menu-item is a necessary class for styling. Also, ‘submenu’ is a necessary class for the dropdowns if you are using a plugin that removes those core classes from the menu items then a filter like this will be required. This is an intentional change to make the menu css more specific so doing custom things with the dropdowns is easier.

    Ben

    hi! yess

    I just wanted to say that I find it curious. that those classes disappear after version 1.30.0 of kadence. Have you changed something in the walker?

    jc menu and kadence were working correctly until these new updates

    thx!

    Hi,
    We didn’t change the walker. We made it so the css expects those core classes. previously the css was less specific which was causing issues because any child of the navigation was getting link styling for example.

    JC menu would have to be doing something different then the core menu walker to remove those classes. I’m not familiar with JC menu but I can say with confidence we are not messing with the core menu walker.

    I hope that makes sense.

    Ben

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.