WordPress.org

Support

Support » Plugins and Hacks » Dropdown doesn't work in editor

Dropdown doesn't work in editor

  • The dropdown doesn’t work in the editor so I use shortcodes.

    I have the plugin set up on a test site with only one other plugin and that is Ultimate TinyMCE. But even with that deactivated the dropdown doesn’t work. Nothing happens when I click on it.

    I am using the latest release of WordPress 3.6 with the Twenty-Twelve theme. I have tried using it with the Twenty-Thirteen theme but that didn’t work either. (On the Twenty-Thirteen theme, the volume slider also doesn’t work. It’s all black with no way to control it.)

    There definitely has to be some kind of conflict but I haven’t figured it out yet.

    I did try it using WP 3.5.2 with the same results.

    I do like the plugin. I think it is very good. It’s just annoying that I can’t use the dropdown,

    Ron

    http://wordpress.org/plugins/se-html5-album-audio-player/

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author sedevelops

    @sedevelops

    Ron,

    That’s odd. Are you definitely using the Visual Editor?

    I have not run into this issue myself.

    Yes, I’m using the Visual Editor. I thought it was odd too. I should have gotten something from the dropdown, but I got nothing. That’s why I tried it with the other WP themes but no go in any of them.

    As I mentioned, the Ultimate TinyMCE was the only plugin and I disabled it. BTW, I have been testing the Ultimate TinyMCE editor for Josh since the beginning so I am very familiar with it.

    I’m running Firefox v.22 if that helps.

    I test various other plugins for authors but yours is the only one where I’ve gotten no response.

    Josh’s UT plugin does have a shortcode collector in the editor which lists all the shortcodes from all the activated plugins. Your shortcode shows up on there, but like I said, I deactivated UT so I knew it wasn’t interfering.

    BTW, I also flushed the cache, deleted the history and did a few other steps to make sure that FF wasn’t bringing up the old cache.

    I haven’t run this past Josh because your plugin is the only one exhibiting this behavior and Josh is developing a new version of his plugin.

    If you have any ideas, let me know. I can give it a good test since I’m doing it on a local server so I control the whole environment.

    Has anyone else mentioned that the dropdown wasn’t working for them?

    Ron

    Plugin Author sedevelops

    @sedevelops

    Hrm. I’ve removed two calls to console.log from the tinyMCE part of the plugin. I’ve heard that these calls can mess with FF execution.

    Check out version 1.1.0. Did it solve your issue?

    For me, on Mac w/ FireFox 22.0, the dropdown works just fine with 1.1.0.

    I tried version 1.1.0. Still a no go.

    I’ll be out of town today so I won’t get a chance to do much testing.

    I’m using Windows although I don’t think that is the problem. What version of Jquery are you using and what theme?

    I might send Josh a note and see if he can think of why your plugin won’t work. You don’t have that much code as far as the hook goes, so maybe he can spot something I didn’t. I’m sure it’s not a conflict with the UT plugin since I also tested it with the default WP editor and it didn’t work.

    I also gave it a quick look in Firebug and I didn’t see anything unusual there.

    Plugin Author sedevelops

    @sedevelops

    Your investigation is greatly appreciated. I’ve not done much work with tinyMCE as I’m almost never in the visual editor myself.

    But your findings will help me improve the plugin for users who might be encountering the same problem. So thanks, and ill wait to hear from ya.

    Thanks. Likewise, your quick response gives me feedback also.

    I’m trying to see if the method you’re using to hook in to the editor is different from others.

    As admin the “user can” capabilities should be ok. I even commented them out just to check and got the same result.

    I haven’t checked the javascript yet.

    The odd thing is that the dropdown is highlighted when I cursor over it, but I get nothing when I click on it.

    I’m also switching themes to check if there is something there, but so far it is the same on every theme.

    I’m checking this in WP 3.5.2 MS, WP 3.6 and WP 3.7 beta.

    I’ll keep you posted.

    tyekynan

    @tyekynan

    I am having this same issue, tried on chrome and IE. Running WordPress 3.6. Click the drop down and nothing happens.

    tyekynan

    @tyekynan

    Any fix for this?

    Hi tyekynan,

    What editor are you using in WP?

    earthsprite

    @earthsprite

    I’ve got this issue as well. Dropdown doesn’t work with 1 album saved. I’m using the default Visual Editor, but I’ve got a custom button next to it for the Shortcode Exec PHP plugin. Disabling it had no effect.

    earthsprite

    @earthsprite

    I just checked, and the shortcode is not working.

    ‘[SE_Album_player album_id=108]’

    For example, only shows the shortcode string on the actual page. I even tried with EVERY OTHER PLUGIN turned off. Hmm…

    I’ve just installed the plugin on wp version 3.6.1 and one opening the New Album pane I get in the firebug console:

    GET http://localhost:8888/wp-admin/admin-ajax.php?action=get_se_album_list 404 Not Found
    tinymc-plugin.js (line 57)

    “NetworkError: 404 Not Found – http://localhost:8888/wp-admin/admin-ajax.php?action=get_se_album_list

    The url should have been:
    http://localhost:8888/project-name/wp-admin/admin-ajax.php?action=get_se_album_list with <project-name> being the website I am working on.

    Looking into the code in tinymc-plugin.js on line 56 I found:
    xmlhttp.open("GET","/admin-ajax.php?action=get_se_album_list",true);
    Removing the leasing slash so that it becomes:

    xmlhttp.open("GET","admin-ajax.php?action=get_se_album_list",true);

    seems to fix the problem with the incorrect url and populates the dropdown which is now clickable. However when adding it to a post and viewing it I now get:

    GET http://localhost:8888/wp-content/plugins/se-html…er/js/niftyplayer/niftyplayer.js 404 Not Found

    “NetworkError: 404 Not Found – http://localhost:8888/wp-content/plugins/se-html5-album-audio-player/js/niftyplayer/niftyplayer.js

    Which again is the incorrect url. app.js line69 is where the call is made but no matter how I manipulate the url, I can’t get it to work.
    Plus I should really have to change any of the url’s to work so not sure why it won’t work out of the box.

    Cheers

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Dropdown doesn't work in editor’ is closed to new replies.