Support » Plugin: BackWPup - WordPress Backup Plugin » Dropbox: token expires every few months

  • Resolved kundenkarma

    (@kundenkarma)


    I use the Plugin BackWPup and backup my site weekly to Dropbox and I have the Problem, that my token expires every few months. When this happens, the backup failes an I get such a error Message in my log:

    [01-May-2022 05:04:09] Token ist abgelaufen; neues Token wurde erhalten
    [01-May-2022 05:04:38] Token ist abgelaufen; neues Token wurde erhalten
    [01-May-2022 05:05:07] Token ist abgelaufen; neues Token wurde erhalten
    [01-May-2022 05:05:37] Token ist abgelaufen; neues Token wurde erhalten
    [01-May-2022 05:06:05] Token ist abgelaufen; neues Token wurde erhalten
    [01-May-2022 05:06:33] Token ist abgelaufen; neues Token wurde erhalten
    ….
    [01-May-2022 05:13:58] FEHLER: Schritt abgebrochen: zu viele Versuche!
    [01-May-2022 05:13:58] Eine alte Log-Datei gelöscht

    After this problem occurs the buckup will not try the next week, so i don’t get failure messages.

    The problem can be fixed by reautherising the dropbox-Token manually (log into page, reautherise dropbox). But it then will occure again after a few months. This already happend a few times and I wonder, if this is actually a bug in the plugin.

    I read on dropbox (https://developers.dropbox.com/oauth-guide), that it is possible to use ong-lived refresh tokens, which should not require a manually reautherising by the user. Did you use those?

    Can you fix this? Or is it possible to change some settings on my end (eg in my dropbox), so there will be no expiration of my authentification?

    thanks for help
    Jasmin

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Support duongcuong96

    (@duongcuong96)

    @kundenkarma
    [01-May-2022 05:04:09] Token has expired; new token received
    hmm, this actually not a problem, this warning will be removed in the next update, about the actual issue you got: [01-May-2022 05:13:58] ERROR: Step aborted: too many attempts! I think there is an issue there. you could enable debug log, BackWPup > Settings > Logs & set Logging Level to Debug (not translated) and run the job again

    Plugin Support duongcuong96

    (@duongcuong96)

    since we haven’t heard back from you, I’m going to mark it as resolved.
    In case you’re still having problems, feel free to let us know 😉

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.