Support » Plugin: BackWPup - WordPress Backup Plugin » Dropbox API: (35) Unsupported SSL protocol version

  • Resolved hansopanso

    (@hansopanso)


    Hi,

    My site is backed up once a week but this night I had 3 errors. (all the same b.t.w.)

    [22-dec-2013 01:05:12] 1. Try to send backup file to Dropbox …
    [22-dec-2013 01:05:12] ERROR: Dropbox API: (35) Unsupported SSL protocol version

    The I noticed BackWPup got a new version. So I upgraded to 3.1 and tried to reauthenticate Dropbox.
    I got this error:
    Dropbox API: (35) Unsupported SSL protocol version

    Any idea how I can solve this?

    Cheers in advance.

    http://wordpress.org/plugins/backwpup/

Viewing 15 replies - 1 through 15 (of 44 total)
  • I got the same problem. It started on december 20th.
    Updated WP and Backwpup. I even uninstalled and reinstalled Backwpup.
    This did not solve the problem

    Also having the same problem on just one of my websites using BackWPup

    Dropbox API: (35) Unsupported SSL protocol version

    Hoping for a fix 🙂

    I thought it was a single problem for one of my sites. But…. unfortunately the same occurs on other sites too. Please help.

    I have the same problem on all my WP sites. After the last upgrade of Backwpup the backup isn’t saved in my Dropbox account due to the SSL: error.
    What can we do?

    Same problem here, not able to back-up 3 sites.

    Merry Christmas api error 35

    I am surprised nobody from support of Backwpup has responded yet. Seeing all the problems posted here seems to me that this is not issue related to one site of hosting-eviroment.
    If Dropbox changed the API this should be addressed by BackWPup.

    Makes me think what the quality of the Pro plugin would be and if that version has decent support.

    As of now I will stop using Backupwp.

    Same problem here. Tested with previous and recent version of the Plugin

    I noticed the problem after libssl got updated on my Debian server, but I m not sure if this is related to the Dropbox API error

    Caspar

    (@friendlyghost)

    We’re still working on reproducing that particular behavior. The fact we haven’t been able to reproduce it yet might say less about the quality of another product than it does about the quality of the error.
    Any supportive feedback on solving the issue is greatly appreciated. BackWPup has an open GitHub repository for those of you who’d like to contribute and know how to interact on GitHub.

    I see in inc/class-destination-dropbox.php that SSL v3 is forced
    curl_setopt( $ch, CURLOPT_SSLVERSION, 3 );
    and
    curl_setopt( $ch, CURLOPT_CAINFO, BackWPup::get_plugin_data( 'plugindir' ) . '/vendor/cacert.pem' );

    could this problem be related to the certificates ?

    or blame dropbox anyway 😉

    Plugin Author Daniel Hüsken

    (@danielhuesken)

    Hello can you please test the Beta under https://github.com/inpsyde/backwpup ?

    Hello! I have the same problem with message ‘DropBox API: (35) Unsupported SSL protocol version’, I try to test the Beta under https://github.com/inpsyde/backwpup as Daniel said, but the message still the same.

    As Daniel suggested, I cloned the backwpup source from github.
    plugin version 3.1.2-beta

    Dropbox re-authentication still gives error msg:

    API:(35) Unsupported SSL protocol version

    but I noticed whilst forcing a test backup run, that I get the error msg:

    The HTTP response test get an error “SSL certificate problem: self signed certificate”

    Yes, I m using a self signed certificate.
    So I wonder if all those that experience the ‘Unsupported SSL protocol version’ issue are using self signed certificates…

    UPDATE
    the self signed certificate issue seems not to be Dropbox related, but a problem introduced in backwpup release > 3.08
    It occurs even if I try to backup to a local server folder.

    I was still using 3.08 but had NOT this issue.
    So now I have both SSL handshake issues, the Dropbox AND the SSL certicicate, aaaaargh !!

    Using 3.1.1 and the last back-up was 6 weeks ago. (before upgrading)
    Tried uninstalling and reinstalling the plugin. Deleted the app authentication in Dropbox. When connecting to Dropbox the API error occurs. No “apps linked” in Dropbox is being created!

    For now I installed “WordPress Backup to Dropbox”. This connects directly to Dropbox and an “apps linked” in Dropbox is visible. However this has considerably less options.

    Like everyone else….hoping for a solution.

    Cheers for all your work!

    edit: btw. When backing up to a directory, everything works fine.

    In regards to my self-signed certificate issue, I added this certificate on the server to ca-certificates :-0
    Still have to test with backwpup, but this is off topic..

    after doing extensive testing :

      version 3.1.2.beta issues:

    • Dropbox API :(35) Unsupported SSL protocol version
    • SSL certificate problem: self signed certificate””
      version 3.1.1 issues:

    • Dropbox API :(35) Unsupported SSL protocol version
    • SSL certificate problem: self signed certificate
      version 3.0.13 issues:

    • Dropbox API :(35) Unsupported SSL protocol version
    • likely JQuery event handler conflict with other plugin
      version 3.0.8 issue:

    • Dropbox API :(35) Unsupported SSL protocol version

    I can live for the moment with the Dropbox issue, but the self signed certificate is a show stopper since I cannot even run a backup job to a local server folder. If the latter is a curl problem, I would like to know what has changed in backwup > 3.0.13 (I will create new forum thread)

    So I have to stick with 3.08 : -(

Viewing 15 replies - 1 through 15 (of 44 total)
  • The topic ‘Dropbox API: (35) Unsupported SSL protocol version’ is closed to new replies.