Support » Requests and Feedback » drop drag and edit widgets problem in 2.5.1.

  • Drop and drag functionality is not working properly.

    When I add a new “text” widget I cannot edit it, it disappears into the great unknown – however, when I add a new text widget and then hit ‘save’ I can proceed to edit (that is a bit of a pain).

    2.5 was working just fine with drop and drag and edit (in IE7 – don’t know about other browsers). Now it’s all messed up, please can you fix it?


Viewing 10 replies - 1 through 10 (of 10 total)
  • hey, same problem here – unable to move any widgets on my sidebar, they appear in the order they were added.

    Adding a widget causes the page to reload, then page breaks and js no longer works.

    ALSO – unable to add widgets to anything other than sidebar #1. Each time I add something to sidebar #2 or #3 it ends up at the bottom of #1.

    Downgrade to 2.5.0 fixed the problem for me


    When I add a new “text” widget I cannot edit it, it disappears into the great unknown – however, when I add a new text widget and then hit ‘save’ I can proceed to edit (that is a bit of a pain).

    Yep I got the same problem but I can’t even shuffle any widgets around at all which means I cannot organize my sidebar.

    same problem here

    Looks like this is a big bug for 2.5> I just did a search and found heaps more posts about it.

    It’s not really a bug, since I got it working in the end. It seems that this may appear when the files of the old WP are not deleted when 2.5 is uploaded. Besides, there are quite some files edited regarding the widget screen for 2.5.1. Let me quote myself from another thread with some suggestions:

    I completely overcame all my problems with the widgets page John.
    I reuploaded all the widget files, just to be sure they were correct on my server and that helped. Then there is this problem in IE7 (edit fields show only half) that can be easily corrected. The problem with widgets that can be changed is just a matter of “add” then first “save changes” and then “change” the widget and “save changes” again. Widgets that suddenly become empty proved with me another IE problem, but it was solved when I uploaded those few widget php and css files again. It is said to help if you asign names to widgets (and/or put a non-text widget between the text widgets) when changing one, clears the rest, but I haven’t had that problem myself.
    In any case, it is not a 2.5 bug or anything, since it works well me me eventually. In my case I should have deleted all files in the admin and config folders before upgrading (no overwriting).

    Be sure to add, then save, then edit, then save again and save the whole widget section.
    There is also a sollution for the cut off editing screen, but I can’t find that thread this second. Some further reading here:

    Hi all, same problem, only since upgrading last week from 2.5 to 2.5.1
    Unable to drag and drop widgets at all, I’ve been thinking about rolling back to my previous set up, as at least everything was working.
    Will keep trying, anyone have any ideas, please post.
    thanks. mike

    Hi all, thought I’d come back on this one, because its been driving me nuts. Well I tried rolling back, tried a fresh install, nothing was working, couldn’t move anything in my sidebars. Then a miracle, I decided to once again check each plugin after activating them, to see if they were the cause. and hey presto. I got to my last plugin.
    Feedwordpress, for my rss feeds. the moment I activated it, i lost any control over sidebar widgets
    Needless to say its now de-activated and everything working fine,
    but its extremely frustrating and time consumin to track these problems down.
    Good Luck. Mike

    Sorry I know this topic is old but I would like to say that I had the same problem and deactivating Feedwordpress plug-in fixed it for me too.

    Thanks mikey1

    When I ran into the problem in IE 6.0 and 7.0 I tried Firefox and the problem went away. I also noticed that in Firefox there is a spelling checker when writing posts and pages.

    I have the problem that my 2.5.1 does not show the Visual, HTTP and WYSIWYG tool bar. Any suggestions how to turn that on?

    Hi there, take a look in your profile. there should be a a check box for visual editor.
    good luck.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘drop drag and edit widgets problem in 2.5.1.’ is closed to new replies.