Support » Theme: Sydney » drop down submenu stopped working

  • I am having the same issue as others — I just noticed the problem last night, so I assume it happened with the February update. The product/ submenus do not drop down, so it is making navigation very difficult, as this is the most used area on our website. I checked the mobile and it appears to work fine in the hamburger menu. I tried the fixes you suggested in previous forums on this topic: 1) Menu Not Working After Upgrade to 1.75
    cpcusteve (@cpcusteve), 2 weeks, 3 days ago; and 2) Top Menu Glitchy, davidatl (@davidatl), 2 weeks, 2 days ago

    but none of those fixes worked. I’m using Sydney Child, and have tested on firefox, chrome, safari and tor.

    thank you

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 22 total)
  • Hi,

    Thank you for contacting us. I am happy to help with your queries.

    As checked, the sub menu on your website works fine on both desktop and mobile devices.

    Here are the screenshots when checking:

    * On mobile
    * On desktop

    Did you appli any change on your menu?

    Perhaps you are having cache on web browser that should be flushed.

    Regards,
    Kharis

    Thread Starter snakelyone

    (@snakelyone)

    Thanks so much for the response. I have cleared the cache twice, on chrome, tor and firefox but no luck; but i just cleared the cache on safari and it works. What do you think is going on? It is nice to see it working someplace, but I wonder if others see what I see?

    Can I ask whether you’re running the latest versions of your web browsers or not?

    but I wonder if others see what I see?

    Can you share a screen recording to the issue on your end? Use free file hosting like Google Drive to upload your video and link it here.

    It would be better if you can also share a screenshot to your menu setting, as it will hellp better identify the root of this issue.

    Regards,
    Kharis

    You could try changing the invalid CSS in the style.css file in the sydney theme directory, line 857, which is

    #mainnav:not(.mainnav.toggled) li:hover > ul {

    and replace with valid CSS,

    #mainnav li:hover > ul {

    This solved all the problems with menus for me. I’d be interested to know if it fixes your problems?

    Thread Starter snakelyone

    (@snakelyone)

    Unfortunately, when I try to do the screenshot my hovering cursor disappears. So I cannot get a picture of it. I am using the latest Tor, firefox for mac. It literally stopped working over night. Curious as to why? so very strange. Shold I try to do the solution offered by cpcusteve? I saw that fix in another forum and was going to try it, but have not. You say the sub menu works fine as is on your system, but I still do not see it except for on safari, but like I said, I cannot recreated the missing drop down with a screenshot. Do you have a suggestion as to how to show you that with a picture? thanks so much.

    Thread Starter snakelyone

    (@snakelyone)

    Also, a note to add. I just went to the safari version of the site that appears to be working; however it is a cached version of the site and the changes I have made recently are not reflected, thus I question whether the drop down sub menu is actually showing at all?

    Hi,

    @cpcusteve I wrote you areply to your other thread here.

    @snakelyone

    Unfortunately, when I try to do the screenshot my hovering cursor disappears. So I cannot get a picture of it.

    You may want to try recording it with LICEcap program.

    however it is a cached version of the site and the changes I have made recently are not reflected

    Do you have a caching plugin enabled? If so, I’d request trying flushing it each time some changes applied.

    Regards,
    Kharis

    Thread Starter snakelyone

    (@snakelyone)

    Hi Kharis,

    I do not have a caching program. And like I said, this happened out of the blue. here’s a link to the cursor over the “product” with no drop down happening.

    https://drive.google.com/file/d/1uJemIhk4NCH4Kq3GnwIgquIz19DjCvBS/view?usp=sharing

    What else can I do?

    thanks so much!

    Hi,

    Thank you for getting back.

    Can I ask which versions of web browsers you’re running? Are they the latest?

    Regards,
    Kharis

    Thread Starter snakelyone

    (@snakelyone)

    latest safari and firefox and chrome on apple. thanks…some people say it works, but still not for me, so it must be my issue?

    Hi,

    Perhaps it is OS-specific issue or something else. Network cache could possibly not able to load recent version of your website. Try checking your network cache setting. Or try with other network (ISP).

    Regards,
    Kharis

    Thread Starter snakelyone

    (@snakelyone)

    Okay. Thanks for trying. It just started out of the blue. One moment it worked, one it didn’t. So strange and I’m continuing to scratch my head. But the OS specific part makes sense to me. My mac mail sometimes just resets itself out of nowhere. A known problem. Truly appreciate your time!

    Hello,
    i have the same problem on a local install of our webpage. since the sydney update to 1.76 the dropdown menu stopped working.
    i tried to change the css as mentioned above, i cleared all the caches, i re-installed sydney, i deactivated all plugins but there is still no dropdown.
    Is there already a solution for that?
    Thank you
    brrrb

    Hi @brrrb,

    Thank you for chiming in.

    Can you share a link to your website here, so I can inspect your menu directly?

    Regards,
    Kharis

    Hi Kharis,
    the webpage still has sydney 1.51 and there it still works. i have a copy of the page locally running, where the dropdown also worked. only after updating sydney it stopped working.
    i want to avoid that on the live page:
    http://www.sezonieri.at/

    also when i change the php version of the local install, it does not change anything.
    everything is up to date on the local page.
    thank you for your time!
    brrrb

Viewing 15 replies - 1 through 15 (of 22 total)
  • You must be logged in to reply to this topic.