Support » How-To and Troubleshooting » Drop down menus wont open after 3.5 update

Drop down menus wont open after 3.5 update

  • After upgrading to WordPress 3.5, my drop down menus wont work. I deactivated all plug-ins and that didn’t work. But it worked just fine in the “twenty twelve” theme. So that means its a theme issue, only i cant figure out what. Id be happy to make an admin account if someone wants to take a look, or here is the main part of my header.php coding

    <div class=”logo_container”>
    <h1>/”><?php if($logo = of_get_option(‘logo’)){ ?><img src=”<?php echo $logo; ?>” alt=”<?php bloginfo(‘name’); ?>” /><?php }else{ bloginfo(‘name’);}?></h1>
    </div><!– /logo_container –>

    <div class=”navbar”>

    <nav id=”jqueryslidemenu” class=”jqueryslidemenu”>

    if ( has_nav_menu( ‘menu-1’ ) ){
    wp_nav_menu( array(
    ‘theme_location’ => ‘menu-1’,
    ‘container’ => ”,
    ‘items_wrap’ => ‘<ul class=”nav”>%3$s’,
    echo “<ul class=’nav’>”;
    wp_list_pages( array(
    ‘title_li’ => ”)
    echo “”;
    <div class=”clearfix”></div>

    </div><!– /navbar –>

    Thanks for the help!

    Site: http://bdwmedia.com/

Viewing 14 replies - 1 through 14 (of 14 total)
  • Josh


    Moderator and Editor Customizer

    I doubt it’s in your header. It’s most likely an improper usage of javascript or jquery. You’d need to run it through a debugging console to check the errors.

    Never done that before, can you point me in the right direction?



    Moderator and Editor Customizer

    If im reading it correctly, it shows they have all loaded on the page (the drop down arrow does show up on the page), but nothing happens when i hover over it. Im not sure where to look beyond that. I have the console open from the link you provided.

    Nevermind, i found it. It says, “Uncaught Error: Stntax error, unrecognized expression” And then shows the main links for where the drop downs are. Those are the only errors on the page.



    Moderator and Editor Customizer

    I mean.. that’s honestly a little bit beyond the scope of this forum.

    You have been shown the way… young Padawan 😉

    (So, see where the error originates from, and check the syntax on the corresponding line)

    I’ll do my best! Thanks so much for the help. Much farther than when i started.

    Thanks again!



    Moderator and Editor Customizer

    My pleasure – Good Luck!! I’ll be curious if you want to post back after you do some “leg work” 😉

    By the way… what’s the theme?

    Once i get it figured out, ill definitely post back! Its called Vitrux by eneaa. Im really hoping to here back from the dev on his support forum because honestly, jQuery is way over my head. Haha



    Moderator and Editor Customizer

    Lol.. right on. Well, let us know if you haven’t heard anything after 48 hours.

    Alright. Dev fixed it for me! He said the issue was, “The problem was a JS file (js/bootstrap.min.js) with jQuery 1.8.2 and above”

    So its all working now! Woo!

    @bryce can you please better explain your last post regarding the js file. Thanks. I seem to have a similar problem.

    Moderator Andrew Nevins


    Forum moderator

    @npoku If you need further support than that provided in this thread, you can create your own thread.

    Thanks Andrew

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Drop down menus wont open after 3.5 update’ is closed to new replies.