Support » Plugin: Draw Attention » Draw Att with anchored URL only works once

  • Resolved jstuedemann

    (@jstuedemann)


    Hello,
    my landing page has four URL-adressing hotspots (each of three pointing to the same page prefixed by an anchor e.g ….#leistungen, one pointing to a new page). The same side anchoring hotspots only work ON THE FIRST ACCESS:

    > Load page > Click hotspot > Page scrolls – ok
    > Home on same side > Click hotspot > Adress asigned in adressline, but the page doesn’t scroll – not ok

    Notes:
    An active page reload then shows the scrolled situation – nice, but is not the users prospect
    The non-anchored Hotspot works fine (with a little think-about-delay)
    Deinstallations of the plugin and rebuilding hotspots hadn’t have any impact

    I do not know, if a yesterdays HTTP to HTTPS Change of the site is of importance on the problem.

    I’ll enjoy some help because of less alternativ opportunities
    J.Stuedemann / Germany

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Plugin Support Draw Attention Support

    (@wpdrawattention)

    @jstuedemann thank you for contacting us through our email.

    For anybody with similar issues using the Themify page builder, the problem was resolved by also setting the ID name for the section not just the Anchor.

    The hotspots in Draw Attention aren’t actually links, which is why you don’t see the browser indicate that it’s about to follow a link when you put your mouse over them. We have to simulate a link with JavaScript since the hotspots are actually just paths in a svg.

    It seems that Themify allows you to add an anchor to a row, but it does so in a non-standard way, which is why the links from the Draw Attention image can’t work. I think Themify includes some custom code to get that to work, but the developers who built that page builder maybe didn’t consider other plugins that might be relying on the standard way of linking to content within the same page and that they might be breaking those.

    When you’re adding an anchor to your rows, please also add the same text as the ID name. That way our links can work

Viewing 1 replies (of 1 total)
  • You must be logged in to reply to this topic.