WordPress.org

Forums

Drag/Drop of Widgets not working in 3.1? (21 posts)

  1. Mugsy
    Member
    Posted 4 years ago #

    Drag & Drop of widgets doesn't seem to work anymore. I've tried both Firefox 3.6.15 (my primary browser) and IE7, so I'm confident it is not a browser issue.

    If I put my pointer over a widget (anywhere), I get the crosshairs, but then can't drag/move them. For now, I must "Enable Accessibility Mode" on the Widgets page and Add/Remove/Hide widgets manually. Not a huge deal, but certainly less convenient.

    Is this a "bug" or was the feature removed for compatibility reasons?

    (I'm using v3.1, but I only recently noticed this "problem", so it may go back several WP versions.)

  2. esmi
    Forum Moderator
    Posted 4 years ago #

  3. Mugsy
    Member
    Posted 4 years ago #

    Already did. I'm not using "Simple Sidebar Share Widget", "Event Espresso", "Easy Toolbox", or any other widget plugin.

    Next.

  4. esmi
    Forum Moderator
    Posted 4 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Ten theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  5. Mugsy
    Member
    Posted 4 years ago #

    Have you tried:

    - deactivating all plugins

    Yes.

    - switching to the Twenty Ten theme to rule out any theme-specific problems.

    I'm reluctant to change the theme, even momentarily, without a way to disable the website and post a "Please check back later" message. (doing this via a plugin isn't rational when the goal is to disable all plugins to find the error.)

    And if the problem is my theme, then how would I fix it? Also, I'm not sure how a Theme could affect the WP Admin interface?

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

    No inactive plugins. Anything not used was deleted.

  6. esmi
    Forum Moderator
    Posted 4 years ago #

    I'm not sure how a Theme could affect the WP Admin interface?

    Themes can, and sometimes do, adversely affect the Admin UI.

  7. katrinaneufeld
    Member
    Posted 4 years ago #

    I am having the exact same problem. I have ruled out theme and plugin conflicts. Frustrating.

  8. katrinaneufeld
    Member
    Posted 4 years ago #

    CORRECTION: I now believe my theme caused the conflict. I switched to Twenty Ten and all functionality returned.

  9. Mugsy
    Member
    Posted 4 years ago #

    Interesting, Katrina.

    I went ahead (just now) and tried applying the "Twenty-Ten" theme to see if it fixed the problem. It didn't. So I quickly put my old theme back.

    Annoyingly, applying the new theme reset/disabled all my Widgets, forcing me to activate and re-sort each of them (grumble). What a pain.

  10. HeidiSitara
    Member
    Posted 4 years ago #

    I have a clean fresh 3.1. install
    -no active plugins
    -only Twenty Ten theme

    The widgets canĀ“t be dragged
    The Screen option button does not work, neither do the Help button

    When I compare the two installations this one and an old and upgraded version which seems to work fine in 3.1), I can see that in the new one (which does not work), as I click on the Screen options menu up on left corner in the widget page, the following comes up in my browsers url address line:
    http://fjeldvig.no/GenblogEN/wp-admin/widgets.php#screen-options
    When I do the same in the WordPress I upgraded, and which does work, only this comes up when I press the menu:
    http://blogg.fjeldvig.no/wp-admin/widgets.php (there is no "#screen-option" added)

    The same happens when I press the "help" button: "#contextual-help" is added to the url.

  11. Gabe Shackle
    Member
    Posted 4 years ago #

    One thing to check is whether or not you have Accessibility Mode enabled. Try going to the Widgets page and expand the "Screen Options" area. If it's enabled, disable it. Having that enabled will turn off the drag and drop functionality of the widget admin.

  12. Mugsy
    Member
    Posted 4 years ago #

    From my original post:

    For now, I must "Enable Accessibility Mode" on the Widgets page and Add/Remove/Hide widgets manually. Not a huge deal, but certainly less convenient.

    The problem is not anything as simplistic as whether or not "Accessibility Mode" is enabled.

  13. HeidiSitara
    Member
    Posted 4 years ago #

    You are right Mugsy. It was nothing like that.

    Everything was set up right, what I had to do was, in my FTP browser, to copy the admin and content folder back, not once ( the first time nothing changed), but twice. Not to be understood, but after the second time, everthing worked.

    And, not to forget, this was replicas of the same folders!

  14. Mugsy
    Member
    Posted 4 years ago #

    Hello Heidi,

    Based upon your solution, I'm suspicious that my modified "php.ini" in my "admin" folder could be at "fault". I had to modify it by adding: "memory_limit = 128M" to increase the buffer size (some of my pages were so long I couldn't edit them after saving.) I made this seemingly innocuous change a few months ago and had forgotten.

    I haven't tried removing the line, and if my custom theme (in the "content" folder) were to blame, the problem would of shown up long before now.

    I may try removing the line to see what happens later. I'll let everyone know when I do.

  15. kresthomas@gmail.com
    Member
    Posted 4 years ago #

    THE SOLUTION:

    Use the Plugin called:

    Use Google Libraries
    available at: http://wordpress.org/extend/plugins/use-google-libraries/

    this will actively listen to scripts with error & redirect them through google's code library. It fixed several issues at once including, QuickPress not loading, Recent Comments on Dashboard, Drag and Drop Widgets. Try this for an instant fix, or try after disabling/cleaning up active plugins. This issue may have been caused by server issues with memory limits from host. I am off to check to see if this solves my Importer issues of "set time limit" because of same issues. I doubt it works, but worth a shot :P Hope everyone has a happy blogging and development day!

    Kres Thomas
    [sig moderated as per the Forum Rules]

  16. esmi
    Forum Moderator
    Posted 4 years ago #

    That's not a solution. It's just patching over the problems at best. It's important to find out what is causing the problem and fix that - or more problems may simply start piling up.

  17. Quicknote
    Member
    Posted 3 years ago #

    Seven months since the last reply to this topic, has anyone got a solution? This is happening to me right now, and as a result I no longer have a functioning website, ergo, no online aspect to my business.

  18. AstroGremlin
    Member
    Posted 3 years ago #

    Actually, the plugin Use Google Libraries is a solution. I've used it for five months to correct the drag and drop not working on menus problem, and it fixed several other problems. My load time is very fast. Would love to hear a better solution . . . if there is one. Until then, it works.

  19. AstroGremlin
    Member
    Posted 3 years ago #

    At the risk of being accused of spamming, I'm attempting to post this article link Drag and Drop Not Working which describes my experience with Use Google Libraries. Includes a comment from a person it helped.

    When a better alternative is available, would love to hear it. So far haven't seen one.

  20. Mugsy
    Member
    Posted 3 years ago #

    Quicknote,

    Some modified themes break Drag & Drop. The only no-mod "solution" is to simply disable Accessibility Mode (drag & drop) and just use the "Add" function to add widgets manually.

    AccMode is enabled/disabled simply by clicking "Screen Options" on the Widgets menu. When it is enabled, DnD'ing of widgets is replaced with an "Add" link to the right of each widget.

    Hope this helps.

  21. Quicknote
    Member
    Posted 3 years ago #

    Mugsy:

    Screen Options ALSO doesn't work.

    EDIT:

    Well, despite being apprehensive due to reading that it's not a solution and it's just patching over the problem, I installed Use Google Libraries, and now everything works as if by magic.

    It may not be a solution, but at least it actually works.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags