Support » Plugin: Custom Sidebars - Dynamic Widget Area Manager » Drag and Drop function lost?

  • Resolved Melpomene

    (@melpomene)


    Am I alone in finding that since updating to 3.8 the ‘Text’ widget from what used to be the ‘widget area’ can no longer be dragged and dropped into a side bar. The Plug In I’m running is the most up to date so far as I can gather 1.3.1

    Has a new method been introduced for bringing the ‘text’ widget into a sidebar? Or is there a straight-forward upgrade type of confirmation thing I need to do

    So far as I can see at the moment, there is no longer any way for bringing a new text widget into a sidebar?

    http://wordpress.org/plugins/custom-sidebars/

Viewing 15 replies - 1 through 15 (of 23 total)
  • Plugin Contributor Predrag Dubajic WPMU DEV Support

    (@wpmudev-support1)

    Hi @melpomene,

    I hope you are well today and thank you for your question.

    I tested it on WordPress version 3.8 using Custom sidebars plugin version 1.3.1 and it worked fine.

    Are you using WordPress multisite or single site?

    Just try deactivating all other plugins and using WordPress default theme Twenty Twelve. Refer the flowchart image on this page.

    Can you try enabling WP_DEBUG mode and debug logging? To do this, just go to wp-config.php include this:

    define('WP_DEBUG',true);
    define('WP_DEBUG_LOG',true);

    You might already have a line for WP_DEBUG, so just make sure it’s set to true. This will create a log file under wp-content/debug.log with detailed information.

    If you’d like to avoid end users seeing error messages, you can include this as well:

    @ini_set('display_errors',0);
    define('WP_DEBUG_DISPLAY', false);

    This will prevent errors from being displayed, but you can still find them in the log file. For information on this, checkout this wpmu.org article.

    Also check the javascript console for errors. In Chrome go to “View -> Developer -> Javascript Console” and in Firefox you can go to “Tools -> Web Developer -> Consoleā€

    Let me know what errors if any you are getting!

    Best Regards,

    Switching theme and decativating the plug-ins made no differecne. I can move a widget from the ianctive area, but that’s all

    Putting that PHP just crashed everything, and firghtened me to death.

    Having said that, the AIT ‘Guesthouse’ theme is on the verge of getting the boot as I’ve never particularly liked it, nor do I think the level of support is that good either

    The temporary solution that would seem to work is to build a new side bar completely (hardly ideal) as new widgets can go in but are entered sequentially. Once a widget is in it becomes static within the sidebar, so I’ll need to enter them in the order I want them to display. Once I’ve done that, I can then delete the old ones

    Plugin Contributor Predrag Dubajic WPMU DEV Support

    (@wpmudev-support1)

    Hi @melpomene,

    Thank you for your reply.

    Putting that PHP just crashed everything, and firghtened me to death.

    Please tell me exactly what has gone wrong. We have used the provided code many times and it worked fine.

    Where have you added the provided code?

    Let me know your site URL.

    I could not reproduce the same issue you are having on my test site.

    Please help me to reproduce it by telling me all information about your WordPress setup so that i can fix it.

    Can you just create test site having same configuration and check whether the problem persists?

    Kind Regards,

    Many thanks WPMU, you’re clearly trying to help-me-out here, but I fear you could be compromised by my limitations of understanding

    The domain is called affordablefairways.com

    I’ve included a link for you to see how the sidebars operate but I’m not sure it’ll be any good to you is it?

    http://www.affordablefairways.com/our-tours/west-coast-fife-tayside-st-andrews-carnoustie/

    It’s running a theme called ‘Guesthouse’ by a company called AIT. I appear to be running 2.40, albeit 2.42 is the most recent, but its far from clear just how you’re supposed to update this theme. I don’t think this can be the issue however as this problem only developed with the WordPress update to 3.8. I’ve got another domain called faraway-fairways.com which has beent he subject of the update, and the drag and drop facility works on that

    Plugins being run on it include

    All in One SEO, Contact form 7, Wordfence, Easy2MapWordpress, Customsidebars, WP super cache, WordPress SEO, and WordPress Importer

    I put the debug code in as follows

    (Appearance( – (Editor) – (Templates on the right hand side) – selected (config PHP) and simply pasted it in below as the bottom line. This brought up something about a ‘unrecognised’ and ‘foreign’ I seem to recall. I do remember a mini dinosaur appearing though and telling the earth had ended (or words to that affect)

    The problem(s) I have is that I have to follow instructions literally and haven’t really got a clue what tasks I’m performing in these kinds of things but some very basic and general idea

    Just to clarify a bad typo that would otherwise alter the context. This should have read:

    I’ve got another domain called faraway-fairways.com which hasn’t been the subject of the update, and the drag and drop facility works on that

    Plugin Contributor Predrag Dubajic WPMU DEV Support

    (@wpmudev-support1)

    Hi @melpomene,

    The problem(s) I have is that I have to follow instructions literally and haven’t really got a clue what tasks I’m performing in these kinds of things but some very basic and general idea

    I need this type of information so that i can reproduce the issue on my test site and provide you solution on it.

    Unfortunately i couldn’t reproduce it on my test site. I have visited your site and found the following JavaScript message on your site.

    Uncaught TypeError: Object function (e,t){return new x.fn.init(e,t,r)} has no method 'curCSS' jquery-ui-1.8.17.custom.min.js?ver=3.8:9
    3
    Uncaught TypeError: Cannot read property 'length' of undefined jquery.js?ver=1.10.2:3
    Warning: you have included the Google Maps API multiple times on this page. This may cause unexpected errors. main.js:50
    Uncaught TypeError: Cannot call method 'push' of undefined

    I think there may be same error messages in the admin area which is causing this issue.

    Can you just recheck for it?

    Would you mind if I logged in to your site and did some testing? This might help get to the bottom of this faster. If this is ok, just assign me admin role on your site for temporary period. I have already registered on your site with same user name.

    Regards,

    Many thanks

    I’ve registered you and given you the protocol requested

    Plugin Contributor Predrag Dubajic WPMU DEV Support

    (@wpmudev-support1)

    Hi @melpomene,

    Thank you for grating me permission.

    I checked it adding text widget and it worked fine. I also tried to move text widget and it moved successfully.

    Let me know specifically on which sidebar you are facing the problem.

    Regards,

    Thanks (I think) as I’m at a bit of a loss then

    I can’t drag and drop anything from the ‘available widgets’ into an existing side bar. It’s as if the widget simply isn’t picking up when I click on it. I can add a widget by clicking on it and specifying which side bar I want it to go. That puts its at the foot of a list, so in the worst case scenario I can rebuild from there and delete those above it. OK it’s not ideal, but it will at least work.

    I’m inclined to ask if there’s something really silly I could be doing regarding the basics of drag and drop, but then I’ve put enough of these in drag and drop before, and it worked fine until 3.8. It was working fine on my other site simultaneously as that one was updated to 3.8 about 24 hours later. One’s inclined to think there must be something lurking in my machine then? but if it was something unique to the local machine it wouldn’t haven’t worked on either, but for a 24 hour period I could operate one but not the other

    As I’ve kind of alluded to though, it isn’t a priority in that I can at least add widgets (albeit a long way round) but I’m at a loss to understand this in truth

    Plugin Contributor Predrag Dubajic WPMU DEV Support

    (@wpmudev-support1)

    Hi @melpomene,

    I rechecked it again on your site and now it’s working slowly and sometime doesn’t work at all.

    There must be something wrong in your WordPress install as it works on my test site but as you have said, you tried switching to default theme and deactivating all plug-ins resulting in no difference then there may not be any issue in theme or plugin.

    Can you just test it on new test site using WordPress 3.8, Twenty Twelve theme and latest version of Custom sidebars plugin?

    If it works fine then try using all same plugins and theme on your test site and check whether it works or not.

    Regards,

    I wanted to briefly say thanks for the help you’ve supplied, as I think that deserves public acknowledgement. I must confess however, that i simply haven’t been able to get round to addressing this today, so I apologise for that as I am concious that its a bit naughty to do so when someone is trying to assist you.

    I’m currently grappling with a CSS issue and trying to build another site. I wish I knew where I could get simple CSS instruction from!!!! As Alexander Pope said, “a little knowledge is a dangerous thing” and i feel that’s the stage I’m at. I can see what needs doing, and can broadly work out about 70% of it, but I simply don’t know where to look in the ‘inspect element’ to lift the coding from, what to call the elements, and probably how to construct it. 70% ain’t good enough though. It equals “won’t work”

    I will give some attention to these sidebars on Friday (oh crikey it is Friday) tomorrow I mean

    Plugin Contributor Predrag Dubajic WPMU DEV Support

    (@wpmudev-support1)

    Hi @melpomene,

    Could you please let me the result of your testing if you have performed it so that i can help you to resolve your issue?

    Kind Regards,

    Ah sorry about that. I am conscious that people who ask for support really should have the decency to follow guidance given etc but I’ve just reached a semi-break in what’s currently pinning me down, so I’ll attend to this now.

    The theme authors did get back to me with the following gem

    “Hi, this is not our plugin, so please contact their support.”

    I don’t really have a test site as such. What I had was two independent sites running the same theme. The 3.8 update went through at a 24 hour interval. One of them I’d performed the plug in work on before it happened and so that was unaffected (it probably is now – I’ll check)

    Right i possibly misunderstood what you were advising. Yes I’m building a new site in a completely different theme (Woo) so I could give that a try

    I’ve taken a barely populated wordpress site of 3.8 and put all the same plug ins into it (minus super cache) and ran it on 2012 and the side bar widgets worked.

    I then switched that the AIT’s ‘Guest House’ theme and they failed

    That would seem to point the finger at the theme?

Viewing 15 replies - 1 through 15 (of 23 total)
  • The topic ‘Drag and Drop function lost?’ is closed to new replies.